• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2272
  • Last Modified:

Netapp, Hyper-V R2, and MPIO network settings

We have a Netapp 2020 with an active/active configuration. We have a 3 node Hyper-V in a Failover Cluster. I have 2 physical NICs on each node dedicated to the "iscsi subnet" of 10.0.1.x. Our Netapp has 2 controllers 10.0.1.11 & 10.0.1.12 that is in a Load Balanced Pair which is channeled on the switch. I have mpio installed and running on each node. The MPIO is setup correctly, as far as I know, but we did some network testing today and there is only one active NIC on each node for iSCSI. In the cluster networks section of the Failover Cluster, the 10.0.1.0/24 subnet only has 3 NICs instead of 6, but I'm assuming that's by design. I've only been working with failover clusters for 9 months so obviously I could be missing something. So although the MPIO is setup to see the NETAPP LUN disks, it's only using 1 of 2 NICs on each node. If anybody could shed some light on this, it would be appreciated.
0
TVAN01
Asked:
TVAN01
  • 4
  • 2
1 Solution
 
TG TranIT guyCommented:
By default - MPIO sets all drives to Round Robin policy.  You can change that by go to properties of each drive and select the MPIO tab.  There you would be able to set to various policy available along with active path and other settings.

MPCLAIM is the command-line equivalent if you are a keyboard ninja :)
Good link to mpclaim usage:
http://geekswithblogs.net/cajunmcse/archive/2010/01/09/mpio-with-windows-2008-r2-server-core-and-iscsi.aspx


mpio.JPG
0
 
TVAN01Author Commented:
Not sure how to really explain my problem, but I have all of the LUNs set to Least Queue Depth, but it only recognizes one path. I guess my problem lies in a network setup or the mpio is not setup correctly. Only one of the 2 nics dedicated to iSCSI traffic is active. The other NIC has no packets being sent or received from it. Here is the properties of one of the nodes iscsicpl. Not sure where you get all those fancy options, but it's clear it's only seeing the one path.


mpio.jpg
0
 
TVAN01Author Commented:
Anybody have another idea on this or do I have to go about opening a ticket with Netapp or Microsoft?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
TG TranIT guyCommented:
You have both paths (NIC) added to MPIO right?

Have you tried to undo the channeling of the NetApp NICs?  Channel is configured binding multiple switch ports into one combined port - maybe this is the culprit
0
 
TVAN01Author Commented:
With the help of our local netapp engineer, not Netapp or Microsoft, we resolved this. I didn't realize that you actually have to add an additional iscsi session. For Netapp in the SnapDrive application under iscsi management, you have to click on the identifier and then do an additional Establish Connection which you will then select the unused NIC.
0
 
TVAN01Author Commented:
Sorry I didn't notice you had this solution out there. I actually didn't have both paths added.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now