Solved

Setting up a Caching Only DNS Server on CentOS 5.5

Posted on 2010-09-14
6
966 Views
Last Modified: 2012-05-10
We have the need to set up a CentOS 5.5 server to act as a DNS Caching server to do lookups.  This server will not provide any zone hosting.  It is simply so that we do not have to rely on our ISPs DNS servers for our client systems.   We would however want to make sure that only that clients within our IP ranges are allowed to use the server for DNS lookups.

Does anyone have an easy HowTo?  I have searched and foudn some references but I just cant seem to get things working in the most basic of scenarios.
0
Comment
Question by:BladesAway
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
6 Comments
 
LVL 35

Accepted Solution

by:
Seth Simmons earned 300 total points
ID: 33678425
http://www.adminkernel.com/linux/bind-dns-server-installation-and-configuration-on-centos-5-3

You could write iptables rules for allowing only certain hosts on udp 53
0
 

Author Comment

by:BladesAway
ID: 33678496
That breings me right back to one of the issues that I was having, which is the mixxing named.rfc1912.zones file.  I was able to find that in the /usr/share/doc/bind-9.3.6/sample/etc/ and I moved it to /var/named/chroot/etc.  They when I start named I get what is displayed below.  I guess I could just locate and copy each of these files but I'm pretty sure I tried that last night and just got deeper into the weeds.

[root@centos etc]# service named start
Starting named:
Error in named configuration:
zone localdomain/IN: loading master file localdomain.zone: file not found
_default/localdomain/IN: file not found
zone localhost/IN: loading master file localhost.zone: file not found
_default/localhost/IN: file not found
zone 0.0.127.in-addr.arpa/IN: loading master file named.local: file not found
_default/0.0.127.in-addr.arpa/IN: file not found
zone 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: loading master file named.ip6.local: file not found
_default/0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: file not found
zone 255.in-addr.arpa/IN: loading master file named.broadcast: file not found
_default/255.in-addr.arpa/IN: file not found
zone 0.in-addr.arpa/IN: loading master file named.zero: file not found
_default/0.in-addr.arpa/IN: file not found
[FAILED]
0
 
LVL 78

Assisted Solution

by:arnold
arnold earned 200 total points
ID: 33678712
post the named.conf
In chrooted setup which is what you seems to have the files should be in /var/name/chroot/var/named/.



0
 
LVL 78

Expert Comment

by:arnold
ID: 34815050
The link http:#33678425 resolves/provides a user a guide to setup a caching DNS.

The user seems to have added entries to /etc/named.conf but did not create the corresponding zone files nor responded to my followup to see whether the asker somehow altered where named would be looking for these files.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
I've written instructions for one router type, but this principle may be useful for others of the same brand and even other brands of router. Problem: I had an issue especially with mobile devices that refused to use DNS information supplied via…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question