Solved

Cannot RDP to XP Desktop

Posted on 2010-09-14
11
743 Views
Last Modified: 2012-05-10
I am having problems with one computer on the domain. I can't RDP to it.
When I try to connect I get an error message saying "This Computer can't connect to the remote computer". "Try connecting again. If the problem continues contact the owner of the remote computer or your network administrator" I get this message from any computer, inside or out that I am using.

The computer is XPP SP3. There is no 3rd party firewall on the computer. The computer is on a SBS2008 domain. I have verified that Port 3389 is open and I can connect to the computer using VNC. I have read that screen resolution can hamper this, I have modified the resolution to 1024x768 without getting any access. I found a hot fix for SP2 but when I tried to apply it I was advised that the fix was already applied.

I am stumped! What am I missing?
0
Comment
Question by:LostInWindows
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
  • +3
11 Comments
 
LVL 14

Assisted Solution

by:Dhiraj Mutha
Dhiraj Mutha earned 125 total points
ID: 33679156
Try reinstalling the RDP client (http://support.microsoft.com/kb/969084). Also check wheater you are able to RDP that system from any other place. Also the check the IP Address and DNS settings.
0
 
LVL 2

Assisted Solution

by:coronoahcoro
coronoahcoro earned 125 total points
ID: 33679215
Did you allow the RD connection to be made? Have you tried turning off windows firewall on that PC?
0
 
LVL 11

Expert Comment

by:sumeshbnr
ID: 33679230
have you enabled remote desktop under my computer properties?
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 4

Assisted Solution

by:timexist
timexist earned 125 total points
ID: 33679407
1, go to system under control panel, under remote tab, "Allow users to conttect remotely to this computer" should be selected, also click the select remote users button, proper users should in the list.

2, remote destop should be selected in xp firewall exceptions.


0
 
LVL 1

Author Comment

by:LostInWindows
ID: 33681604
Remote connections are allowed.
I cannot turn off the firewall because of GP.
Remote Desktop is listed in the firewall rules.
0
 
LVL 9

Assisted Solution

by:Timothy McCartney
Timothy McCartney earned 125 total points
ID: 33682116
Are you able to ping the desired workstation?

Run > CMD > "ping [desired IP or hostname]"

Let us know if you get any replies
0
 
LVL 1

Author Comment

by:LostInWindows
ID: 33682175
Yes, I get replies
0
 
LVL 2

Expert Comment

by:coronoahcoro
ID: 33682384
hmm I've had cases where Remote Desktop is listed in the firewall rules but I can't access the PC without turning off the firewall. I wonder if there is a way to bypass the GP so the Local Admin can change the firewall settings...
0
 
LVL 14

Expert Comment

by:Dhiraj Mutha
ID: 33683075
Try reinstalling the RDP client (http://support.microsoft.com/kb/969084). Also check wheater you are able to RDP that system from any other place. Also the check the IP Address and DNS settings.
0
 
LVL 1

Author Comment

by:LostInWindows
ID: 33691395
I tried reinstalling the client and now I get different messages but still no connection. The Message Title is "VBScript Remote Desktop Disconnected" The message body says "The computer you are trying to connect to cannot be contacted. Verify that it is turned on awake ..."
I ran the MS Port Scanner and port 3389 is not listed. When I tried to add it as a firewall exception it wouldn't allow me to because it already exists.
I am thinking that I need to remove this machine from the domain, fix up the firewall they rejoin it back to the domain. Is there a better way to handle this? Is this considered an extreme action?
What would you suggest?
0
 
LVL 1

Accepted Solution

by:
LostInWindows earned 0 total points
ID: 33760841
I found the problem. The RDP Port number had been changed in the registry.
0

Featured Post

Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Because virtualization becomes more and more common, and, with Microsoft Hyper-V included in Windows Server at no additional costs, and, most server hardware nowadays is more than capable of running a physical Small Business Server (SBS) 2008 or 201…
If you are a user of the discontinued Microsoft Office Accounting 2008 (MSOA) and have to move to a new computer running Windows 8, you will be unhappy to discover that it won't install.  In particular, Microsoft SQL Server 2005 Express Edition (SSE…
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question