Solved

Bootmgr is missing but previous install not found

Posted on 2010-09-14
8
1,031 Views
Last Modified: 2012-05-10
Hello

I am trying to fix a 'BOOTMGR is missing'  error, but have run into problems as neither startup repair nor Windows 7 repair disk can find the hard drive.

Below is the complete backstory:

I recently purchased an external HD to back up my growing amount of data, but discovered, after having copied a large amount to it, that it was only fat32 and unable to hold my large files. I decided to convert it using Partition Magic 8, which I had not used in years. I installed it, stupidly ignoring the 'known compatibility issues' that it has with windows 7.

At first run, it scanned my hard drives and came up with a couple 'errors' that it had caught and could 'fix'. Since I have had for some time now a partition that has a corrupt file table, I clicked away at all the errors, letting PM8 fix them. I noticed that it called one of my 500gb drives and my internal TB drive 'BAD', but thought nothing of it at the time. I started the conversion and let it reboot to finisht.

The first time it booted, after the windows logo the PM8 screen came up properly and started the conversion. It finished and I let it reboot.

Then came the problems. Partway through the logo animation, the computer BSOD'd and boot-looped. I shut it down, detached the External HD, and went for startup repair.

Startup repair ran smoothly the first time, and brought me into, surprisingly, an other copy of 7 stored on another internal hard drive that had been abandoned but not deleted. This copy could not see my main 1TB hard drive, only showing me the partitions on my 2 500GBs. Nor could it run the Device Manager.

Worried about my data, I booted a liveCD ubuntu, which could see and open the TB drive's two partitions, though it read the 30GB OS partition as a '106MB file system'. Checking the external HD, it seems that PM8 did not convert it to FAT32.

I rebooted and tossed in a windows 7 disk to attempt a repair. The Repair program did not find any installations of windows 7, nor could browsing the computer for drivers find the partitions on the internal TB drive. I ran startup repair from System Recovery Options, and it informed me that a problem had been fixed.

I rebooted, but the computer once again started the older version of 7. This time, device manager worked, and it showed the TB drive correctly,. However, windows was not showing the partitions on it. I went into Disk Manager, where I could see the TB drive, and the partition separation on it, but it stated the type as unreadable. I set my 30GB OS partition as active and rebooted.

It then came up with the 'BOOTMGR is Missing, press CAD to restart message. I went back to the Repair Disk command prompt (once again, the recovery console didn't find ANY installations of windows) and tried running bootrec /fixboot. This gave the message 'The System cannot find  the file specified.'

When I try to run startup repair now it says that the error cannot be fixed by system repair. The Diagnostic details say: Root Cause Found:
System Volume on disk is corrupt.
Repair action: File system repair (chkdsk)
Result: Failed. Error code = 0x3

Can anyone help me get this system working again?
0
Comment
Question by:johndgregory
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 2

Expert Comment

by:VMthinker
ID: 33679245
You could boot up into a Linux live disk etc. Ubuntu or backtrack and use the command "fdisk -l" to check if your OS is still intact.
Or it could be your MBR (Master Boot Record) that is corrupted which you need to go this website and follow the repair steps: http://askbobrankin.com/fix_mbr.html
0
 

Author Comment

by:johndgregory
ID: 33679301
Here is the result of fdisk -l on ubuntu.

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
224 heads, 19 sectors/track, 459004 cylinders
Units = cylinders of 4256 * 512 = 2179072 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x7bc12922

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1          49      103248    7  HPFS/NTFS
/dev/sda2   *          49       19249    40858448    7  HPFS/NTFS
/dev/sda3           19249      459005   935801616    7  HPFS/NTFS


Also, the link you gave is for windows XP, and it gives the command fixmbr. the windows vista/7 version of this is bootrec /fixmbr, which I tried, and it doesn't fix anything despite running fine.
0
 
LVL 1

Accepted Solution

by:
Huntinglodge earned 500 total points
ID: 33679307
"This can be a dangerouse change, and does have the possability of lossing data, so please "DO THIS AT YOUR OWN RISK""  "Backup Data First"

Sounds like your partition table has gotten screwed up.  I would suggest running testdisk on it to restore it.  Be carefull as testdisk is a very powerfull tool and can wipe all the data and partition info off the disk if not run correctly.  

If you have a disk imaging software run that before doing the following, something like Acronis Disk Image or Symantec Ghost, and make a backup of the disk.

I would boot to linux and open terminal and type in testdisk.  Select Create log, and select your hdd in the list it shows up. Select the partition table "Intel"  then Select Analyse, and then select "Quick Search"  In the next option select "Y" for created under Vista.

It will give you a bit of an overview of the partition structure and let you know what is available and setup on the disk.  Hopefully it is showing the "Structure" as OK.  If you hit enter it will giveyou the option to "Quit" "Deeper Search" or "Write"  Hightlight "Deeper Search" and hit enter.  Let it do the search, and if there has been a change to the partition table when it finishes it will show up.  

You wil be able to select the available partition tables and either write it or view files.  I would select view files before writing, and have a look through the structure and confirm that all of your important files are there before writing that partition table back to the disk.  

As I stated at the start this can be a dangerouse change, and does have the possability of lossing data, so please "DO THIS AT YOUR OWN RISK"
0
 
LVL 2

Expert Comment

by:VMthinker
ID: 33679322
I would give you a new advice of just reformating your entire drive.
If you need the data in your hard disk, you'll have to use another hard disk to install another windows 7 OS and connect back your old hard disk and use a 3rd party hard disk recovery tool.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 

Author Comment

by:johndgregory
ID: 33679329
2 things before I try this. First, the system was made by 7. Is it still Y that I put in? Also, there is no chance that it will affect data on my other drives when I do this, correct?

Thankfully, I just back up everything not bigger than 4gb on my TB drive before starting this all...
0
 
LVL 1

Expert Comment

by:Huntinglodge
ID: 33679355
1.  Yeah you can select Y for the Vista question.

2.  If the other drives are different Physical drives then it wont affect them, unless you accidently select them in the list.  If they are on the same physical drive but are just partitions, it has the possibility of corrupting their tables as well.

But in saying that it is just like any other partition/disk management utility, they all have the ability to make things worse.  Best to make sure that everything is backed up first.

Hope that helps.
0
 
LVL 91

Expert Comment

by:nobus
ID: 33679655
disconnect other disks, before playing  - then it can't do anything to them.

for your problem here the MS article on it  - see BCDMD   Repairs the MBR, partition table, or boot sector
 from : http://technet.microsoft.com/en-us/library/cc722188(WS.10).aspx
0
 

Author Closing Comment

by:johndgregory
ID: 33688378
After I used testdisk and did a setup repair from my repair disk, it worked just fine!

It deauth'd my windows install though...
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
While working, an annoying popup showing below will come and we cannot cancel or close it form the screen. The error message will come again and again.
In this Micro Tutorial viewers will learn how to use Boot Corrector from Paragon Rescue Kit Free to identify and fix the boot problems of Windows 7/8/2012R2 etc. As an example is used Windows 2012R2 which lost its active partition flag (often happen…
This Micro Tutorial will teach you how to change your appearance and customize your Windows 7 interface to your unique preference. This will be demonstrated using Windows 7 operating system.

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now