[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 512
  • Last Modified:

Reset user connection on mysql

please i am getting this error through my php application i think i need to reset the established user connections:

Could not connect: User opt_admin already has more than 'max_user_connections' active connections

can some body tell me the best way to reset this.
0
I-Can
Asked:
I-Can
  • 3
  • 3
1 Solution
 
shobinsunCommented:
HI,

Set max_user_connections in php.ini and restart mysql and apache
0
 
I-CanAuthor Commented:
the issue i am using online hosting service and con't restart these services
0
 
shobinsunCommented:
HI,

use ini_set('max_user_connections',500);

in your script
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
I-CanAuthor Commented:
i did try it but still getting the same error

i think such setting i have to do it with mysql not php
0
 
shobinsunCommented:
Hi,

Better to contact the hosting provider to increase the mysql max user connection
0
 
I-CanAuthor Commented:
Thanks a lot i called them and they guide me to kill the process responsible for it.
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now