MSI Windows Installer Package DLL Error

Posted on 2010-09-15
Last Modified: 2012-05-10
To make a long story short, I am trying to install VMware Workstation 7.1.1 on my Windows 7 64bit machine (after a nasty VMware 7.0.1. uninstall). I have finally gotten it to the point where I can run the install (exe or msi) for Workstation and it gets almost to the end and throws this error.

Error 1723. There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor. Action VM_perfMonInstall.05A3DB77_E7FB_4275_AA00_2FC19218E5DA, entry: VMInstallPerfmon, library: C:\Windows\Installer\MSI754C.tmp

It's weird... because by this point in the install the VMware Workstation icons have been added, I can open VMware Workstation (as long as I do not close out of the error) and run it, but once i close out of the error it rolls back the install. Does anyone have any ideas on this one? I have no clue at this point.

Question by:IsaacWeathers
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +1

Expert Comment

ID: 33680347
Try to Right click that setup file choose Run as administrator.
LVL 96

Expert Comment

by:Experienced Member
ID: 33680957
Take a look at this VMware to clean up a failed installation: 0 115400664

That is a very long link, so the KB article ID is 1308.

... Thinkpads_User

Author Comment

ID: 33682689
@shanyuen, already tried that.
Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI


Author Comment

ID: 33682702
@thinkpads_user, already tried that as well.
LVL 96

Accepted Solution

Experienced Member earned 500 total points
ID: 33683742
It is fairly easy to screw up any OS installation, so if you cannot clean up VMware (heavy into your networking and low level OS underpinnings), you may need to consider re-installing Windows to get it to work.

I have VMware V 7 running on two Windows 7 machines and one of them I upgraded from a prior V7 install, so it all works at this level. I had V7.0.1 on this latter machine and it was no issue to allow the V7.1.1 installer to uninstall the prior version and carry on with the new version.

I do not know what else to suggest.  ... Thinkpads_User
LVL 28

Expert Comment

ID: 33685579
I am not sure how to get past the error - but you indicated that workstation starts and runs ok until you close out the error and it all rolls back. You might be able to get around it by starting the install program and letting it run until you hit the error.

Next find the .msi file that was extracted when you ran the setup program - likely it will be in %TEMP%. You can do a search on all files *.msi in %TEMP% and find the newest one, copy that file somewhere safe.

Close out install and let it roll back.

Double click the .msi file you archived earlier - if it hits the error again it shouldn't roll back.

Good Luck

Expert Comment

ID: 33698642
Try to re-download the installer.
It's can be happen if you got corrupt installer.

Author Comment

ID: 33719053
I tried all of the above and it didn't work. FInally had to reinstall Windows to get around the error. Thanks anyways.

Author Closing Comment

ID: 33719067
Didn't address/fix the issue... reinstalling OS isn't really a "solution"...
LVL 96

Expert Comment

by:Experienced Member
ID: 33720499
Thank you. I know that re-installing the OS is a pain, but sometimes it comes to that. So thanks again and for the update. ... Thinkpads_User

Featured Post

[Webinar] How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
Giving access to ESXi shell console is always an issue for IT departments to other Teams, or Projects. We need to find a way so that teams can use ESXTOP for their POCs, or tests without giving them the access to ESXi host shell console with a root …
This video shows you how to use a vSphere client to connect to your ESX host as the root user. Demonstrates the basic connection of bypassing certification set up. Demonstrates how to access the traditional view to begin managing your virtual mac…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question