• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 413
  • Last Modified:

Enable Web Page to run on HTTPS

Hi

We have a glassfish server that run on http we now have to enable https and let the application run on https.

We already installed the certificates
0
abooysen2
Asked:
abooysen2
  • 4
  • 2
2 Solutions
 
collins23Commented:
which version of glassfish ? have you seen this ?

http://www.techbrainwave.com/?p=505
0
 
abooysen2Author Commented:
Version 2
0
 
svgmucCommented:
Try to connect via https (ie. type the same URL as usual, just use https).
If it works, you're done.

Otherwise check

- if https is enabled in the server
- if the https virtual host is using the same document root
- if the documents don't enforce http

After you get it to work, decide if you want https enforced or both options enabled.
You can either enforce it through the scripts or through rewrite rules.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
abooysen2Author Commented:
when we start up our enviroment we get this error

java.net.BindException: Permission denied: 443
0
 
collins23Commented:
it appears another service is already listening on port 443.

you may need to change this port to something like 8443 ( assuming you are not using this port also )
0
 
abooysen2Author Commented:
it's working now. I check the port netstat -anp |grep 443 and used 8443 rather

THanks
0
 
abooysen2Author Commented:
Excellent guidelines
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now