Solved

no internal Audio on voip call behind ASA

Posted on 2010-09-15
13
1,368 Views
Last Modified: 2012-08-13
I have configured a Cisco 7942 IP Phone behind a ASA5505. the phone has registered with the call managers and I can make and recieve calls from the outside just fine. However if I call internally phone to phone I get no audio in either direction. I have enabled the "same-security-traffic permit intra-interface" command to allow for hairpinning as well. Also added inspect statements for SIP and SKINNY. see config.....



:
ASA Version 8.2(2)4
!
hostname Test
domain-name ad.davey-tree.com
enable password vOigZlIColYWIF/6 encrypted
passwd vOigZlIColYWIF/6 encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.30.254.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!

interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa822-4-k8.bin
ftp mode passive
dns server-group DefaultDNS
 domain-name ad.davey-tree.com
same-security-traffic permit intra-interface
access-list IPsec-traffic extended permit ip 10.30.254.0 255.255.255.0 10.1.0.0 255.255.0.0
access-list nonat extended permit ip 10.30.254.0 255.255.255.0 10.1.0.0 255.255.0.0
pager lines 24
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside

icmp permit any echo-reply outside
asdm image disk0:/asdm-625.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
url-server (inside) vendor websense host 10.1.200.110 timeout 30 protocol TCP version 4 connections 5
url-cache dst 128
filter url http 0.0.0.0 0.0.0.0 0.0.0.0 0.0.0.0 allow longurl-truncate
filter url 443 0.0.0.0 0.0.0.0 0.0.0.0 0.0.0.0 allow
http server enable
http 192.168.1.0 255.255.255.0 inside
http 10.1.200.10 255.255.255.255 inside
http 10.30.254.0 255.255.255.0 inside
http 10.1.3.3 255.255.255.255 inside
snmp-server host inside 10.1.200.10 community *****

no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ASA esp-3des esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map IPSEC 10 match address IPsec-traffic
crypto map IPSEC 10 set peer 1.2.3.4
crypto map IPSEC 10 set transform-set ASA
crypto map IPSEC 10 set security-association lifetime seconds 28800
crypto map IPSEC interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
crypto isakmp policy 65535
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh 10.0.0.0 255.0.0.0 inside
ssh timeout 5
console timeout 0
management-access inside
dhcpd dns 10.1.200.108 10.1.200.16
dhcpd wins 10.1.200.17
dhcpd domain ad.davey-tree.com
dhcpd auto_config outside
dhcpd option 150 ip 10.1.12.10 10.1.12.11
!
dhcpd address 10.30.254.10-10.30.254.30 inside
dhcpd enable inside
!

no threat-detection basic-threat
no threat-detection statistics access-list
no threat-detection statistics tcp-intercept
url-block url-mempool 1500
url-block url-size 4
tftp-server inside 10.30.254.10 /
webvpn
tunnel-group 1.2.3.4 type ipsec-l2l

tunnel-group 1.2.3.4 ipsec-attributes
 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny  
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip  
  inspect xdmcp
  inspect icmp
!
service-policy global_policy global
prompt hostname context
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:e10d68c04398b2a8bf5396cb818e7846
: end
0
Comment
Question by:dtadmin
  • 7
  • 6
13 Comments
 
LVL 33

Expert Comment

by:MikeKane
Comment Utility
If the phones can establish a call, but not transfer audio, its usually an Access-list issue.   But I'm a little confused as to the layout of the network.     I only see the one vlan interface on the ASA for inside, but you have more subnets defined 10.30. and 10.1 .     Is there a 2nd gateway out of the 10.30 subnet?  
0
 

Author Comment

by:dtadmin
Comment Utility
no. the ASA only has one subnet behind it. The other you see in the ACL was me playing around trying to get it to work.
0
 

Author Comment

by:dtadmin
Comment Utility
actually the 10.30 subnet is the asa at the remote site.
the 10.1 subnet is my corporate subnet where the call managers reside.
0
 
LVL 33

Expert Comment

by:MikeKane
Comment Utility
Are these phones registering via SIP outside the network or are they using a call manager inside the network?  

So the phones are registering via SIP and can establish a call, but no audio back and forth correct?  If the call is established, then the PBX has done its work, and now the traffic is from phone to phone directly.    

Question:   if you make a call outside the network, doe sit work correctly?  

Question:  if you take the 2nd phone outside the network, does it work correctly?

0
 

Author Comment

by:dtadmin
Comment Utility
they are registering to a call manager inside the network.

Yes. When I make a call from the ip phone behind the ASA to my cell phone the call completes with audio.
0
 
LVL 33

Expert Comment

by:MikeKane
Comment Utility
If they are registering to a call manager on the same subnet, then when the call is established, the CCM is done.  After that, its phone to phone.     Are the phones on same subnet?   can the phones ping each other?   What codec are you using?  Is it the same on both phones?
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:dtadmin
Comment Utility
the phones are on separate subnets. The phone behind the asa is on the 10.30.254.0/24 subnet; the phone at my corporate office is on a 10.2.0.0/24 subnet. I am using G.711 codec all the way through.
0
 
LVL 33

Expert Comment

by:MikeKane
Comment Utility
OK, where is the 10.2.0.0 network in relation to the 10.30.254 network, because I see no routing on the ASA....     Is there another gateway?   How are the packets routed?   What device is in between the 2 networks?    

Has this ever worked before or is this a new setup?
0
 

Author Comment

by:dtadmin
Comment Utility
new setup....
the 10.30.254 network is behind an asa5505 remote office which is connected to our corporate asa5520 via dynamic VPN tunnel. the 10.2.0 network is located at my corporate office.
0
 

Author Comment

by:dtadmin
Comment Utility
i added the 10.2 network to my ipsec and nonat ACL's on the 5505; maybe I need to add the 10.2 subnet to the nonat ACL on my corporate asa????
0
 
LVL 33

Accepted Solution

by:
MikeKane earned 500 total points
Comment Utility
On the ASA tunnels, both sides must be no-nat'ed for traffic to flow correctly.    
0
 

Author Comment

by:dtadmin
Comment Utility
roger. I'll modify the ACL's on the corporate side and update this thread.
0
 
LVL 33

Expert Comment

by:MikeKane
Comment Utility
Any Luck?
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Skype is a P2P (Peer to Peer) instant messaging and VOIP (Voice over IP) service – as well as a whole lot more.
Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now