Solved

Pass traffic from LAN to remote VPN subnets by non-local source address on an ASA

Posted on 2010-09-15
3
667 Views
Last Modified: 2013-11-16
Hi,

I need to be able to get traffic from local VLAN's (10.10.0.0/16) to various networks over a VPN (10.255.255.0/24, 10.253.0.0/16) but my local source address range has to 10.120.15.0/28 for the VPN.

The gateway for the LAN is a Catalyst 6500 series switch 10.10.0.254 which handles all the L3 routing internally, the ASA on 10.10.0.1 is the gateway for the switch.

The VPN is up, that not a problem it just how to get the traffic from the LAN for the remote networks to go via the tunnel?

Hope you can help!

Here is the config:

: Saved
:
ASA Version 8.2(1)
!
hostname asa

names
name 192.150.18.108 Adobe-1
name 192.150.11.247 Adobe-2
name 192.150.11.30 Adobe-3
name 192.150.22.30 Adobe-4
name 192.150.22.40 Adobe-5
name 10.10.50.0 MacNetwork description Mac Network

name 10.10.10.5 rbrowndigital description rbrowndigital Web Server
name 10.10.10.6 rbrownnt6 description rbrownnt6 Email Server
name 10.10.0.0 allvlans
name 10.10.10.4 rbrownnt4 description Rbrownnt4 Proxy

name 192.168.192.250 MorePayServer2
name 10.10.10.0 ServerVlan

name 10.10.59.0 Vlan59

name 10.10.10.15 InternalDownloadServer
name x.x.x.x DDS-168-2
name 10.255.255.0 DDSInternal1 description DDSInternal1
name 10.255.30.0 DDSInternal2 description DDSInternal2
name 10.255.5.0 DDSInternal3 description DDSInternal3
name 10.255.4.0 DDSInternal4 description DDSInternal4
name 10.253.0.0 DDSInternal5 description DDSInternal5
name 168.x.x.x DDSInternal6 description DDSInternal6
name 10.120.15.0 DDS_NAT_Src_Pool
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.10.0.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address x.x.x.x 255.255.255.240
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
object-group network Adobe
 description Adobe
 network-object host Adobe-2
 network-object host Adobe-3
 network-object host Adobe-1
 network-object host Adobe-4
 network-object host Adobe-5
object-group network DDS
 network-object DDSInternal5 255.255.0.0
 network-object DDSInternal1 255.255.255.0
 network-object DDSInternal2 255.255.255.0
 network-object DDSInternal4 255.255.255.0
 network-object DDSInternal3 255.255.255.0
 network-object DDSInternal6 255.255.255.0
object-group network SMTP-Inbound
 description Websense Mailcontrol.com
 network-object Mailcontrol.com-2 255.255.248.0
 network-object Mailcontrol.com-1 255.255.248.0
 network-object Mailcontrol.com-3 255.255.248.0
 network-object x.x.x.x 255.255.224.0
object-group service 8080 tcp
 port-object eq 8080
object-group service BT tcp-udp
 port-object range 6881 6889
object-group service Blackberry tcp-udp
 port-object eq 3101
object-group service DDS4500 tcp-udp
 port-object eq 4500
object-group service DDS50 tcp
 port-object eq 50
object-group service DDS500 udp
 port-object eq isakmp
object-group service MassTransit tcp-udp
 port-object eq 50000
object-group service MorePay tcp-udp
 port-object eq 22
object-group service OnTime tcp-udp
 port-object eq 1334
object-group service Palace-6 tcp-udp
 port-object eq 9997
object-group protocol TCPUDP
 protocol-object udp
 protocol-object tcp
object-group service TSG-Remote tcp-udp
 port-object eq 5721
object-group service Video tcp-udp
 port-object eq 443
 port-object range 50000 59999
 port-object range sip 5062
 port-object eq 8057
object-group network ExternalFtpServers
 network-object host 217.150.116.43
 network-object host ExternalFtpServer18
 network-object host ExternalFtpServer8
 network-object host ExternalFtpServer6
 network-object host ExternalFtpServer22
 network-object host ExternalFtpServer16
 network-object host ExternalFtpServer19
 network-object host ExternalFtpServer10
 network-object host ExternalFtpServer14
 network-object host ExternalFtpServer11
 network-object host ExternalFtpServer13
 network-object host ExternalFtpServer17
 network-object host ExternalFtpServer7
 network-object host ExternalFtpServer21
 network-object host ExternalFtpServer12
 network-object host ExternalFtpServer9
 network-object host ExternalFtpServer15
 network-object host OnTimeServer1
 network-object host ExternalFtpServer3
 network-object host ExternalFtpServer5
 network-object host ExternalFtpServer4
 network-object host ExternalFtpServer23
 network-object host ExternalFtpServer20
 network-object host ExternalFtpServer25
 network-object host ExternalFtpServer26
 network-object host ExternalFtpServer24
object-group network OnTimeServers
 network-object host OnTimeServer1
 network-object host OnTimeServer2
object-group service DM_INLINE_TCP_1 tcp
 group-object OnTime
 port-object eq sqlnet
object-group network ExternalWebServers
 network-object host HttpServer2
 network-object host HttpServer1
object-group network MorePayServers
 network-object host MorePayServer2
 network-object host MorePayServer
object-group network UnrestrictedServers
 network-object host UnrestrictedServer1
 network-object host UnrestrictedServer2
object-group service DM_INLINE_SERVICE_1
 service-object gre
 service-object tcp eq pptp
access-list inside_access_in extended permit tcp any object-group DDS object-group DDS50
access-list inside_access_in extended permit udp any object-group DDS object-group DDS500
access-list inside_access_in extended permit object-group TCPUDP any object-group DDS object-group DDS4500
access-list inside_access_in extended permit ip MacNetwork 255.255.255.0 object-group Adobe
access-list inside_access_in extended permit tcp any any eq https
access-list inside_access_in extended permit tcp host 10.10.59.100 host x.x.x.x eq ftp
access-list inside_access_in extended permit tcp any object-group ExternalFtpServers eq ftp
access-list inside_access_in extended permit tcp any object-group OnTimeServers object-group DM_INLINE_TCP_1
access-list inside_access_in extended permit tcp any object-group MorePayServers object-group MorePay
access-list inside_access_in extended permit object-group TCPUDP any any object-group TSG-Remote
access-list inside_access_in extended permit tcp any object-group ExternalWebServers eq www
access-list inside_access_in extended permit ip any object-group UnrestrictedServers
access-list inside_access_in extended permit ip ServerVlan 255.255.255.0 any
access-list inside_access_in extended permit ip Vlan59 255.255.255.0 any
access-list inside_access_in extended permit object-group TCPUDP any any object-group MassTransit
access-list inside_access_in extended permit object-group TCPUDP any any object-group Palace-6
access-list inside_access_in extended permit ip DDS_NAT_Src_Pool 255.255.255.240 object-group DDS
access-list outside_access_in remark Allow SMTP inbound from mailcontrol.com
access-list outside_access_in extended permit ip object-group SMTP-Inbound x.x.x.x 255.255.255.240
access-list outside_access_in remark Allow access to HTTP web servers
access-list outside_access_in extended permit tcp any x.x.x.x 255.255.255.240 eq www
access-list outside_access_in remark Access to HTTPS web servers
access-list outside_access_in extended permit tcp any x.x.x.x 255.255.255.240 eq https
access-list outside_access_in extended permit object-group DM_INLINE_SERVICE_1 any host 82.109.166.228
access-list outside_1_cryptomap extended permit ip DDS_NAT_Src_Pool 255.255.255.240 object-group DDS
access-list inside_nat0_outbound extended permit ip DDS_NAT_Src_Pool 255.255.255.240 object-group DDS
access-list CiscoRemote_splitTunnelAcl standard permit robsonbrownallvlans 255.255.0.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool rapool 172.16.1.1-172.16.1.254 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 101 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 101 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface https rbrownnt6 https netmask 255.255.255.255
static (inside,outside) tcp interface smtp rbrownnt6 smtp netmask 255.255.255.255
static (inside,outside) tcp WebServer www rbrowndigital www netmask 255.255.255.255
static (inside,outside) tcp interface www InternalDownloadServer www netmask 255.255.255.255
static (inside,outside) 82.109.166.228 rbrownnt4 netmask 255.255.255.255
access-group inside_access_in in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
route inside ServerVlan 255.255.255.0 10.10.0.254 2
route inside MacNetwork 255.255.255.0 10.10.0.254 10
route inside 10.10.51.0 255.255.255.0 10.10.0.254 10
route inside Vlan59 255.255.255.0 10.10.0.254 10
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa-server rbrownnt6 protocol radius
aaa-server rbrownnt6 (inside) host rbrownnt6
 timeout 5
 key R0bs0nbr0wnradius
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
http server enable 4430
http robsonbrownallvlans 255.255.255.0 inside
http 217.37.131.137 255.255.255.255 outside
http 82.71.194.253 255.255.255.255 outside
http ServerVlan 255.255.255.0 inside
http 188.220.34.185 255.255.255.255 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec security-association lifetime seconds 86400
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set peer DDS-168-2
crypto map outside_map 1 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
crypto isakmp policy 65535
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh allvlans 255.255.255.0 inside
ssh ServerVlan 255.255.255.0 inside
ssh x.x.x.x 255.255.255.255 outside
ssh x.x.x.x 255.255.255.255 outside
ssh timeout 5
console timeout 0

priority-queue inside
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy CiscoRemote internal
group-policy CiscoRemote attributes
 dns-server value 10.10.10.1 10.10.10.4
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value CiscoRemote_splitTunnelAcl
 default-domain value new.r

tunnel-group x.x.x.x type ipsec-l2l
tunnel-group x.x.x.x ipsec-attributes
 pre-shared-key *
tunnel-group CiscoRemote type remote-access
tunnel-group CiscoRemote general-attributes
 address-pool rapool
 authentication-server-group rbrownnt6
 default-group-policy CiscoRemote
tunnel-group CiscoRemote ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny  
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip  
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:b127b4395c989c8ad9e1b424de2277b6
: end
asdm location rbrowndigital 255.255.255.255 inside
asdm location rbrownnt6 255.255.255.255 inside
asdm location MacNetwork 255.255.255.0 inside
asdm location WebServer 255.255.255.255 inside
asdm location allvlans 255.255.0.0 inside
asdm location rbrownnt4 255.255.255.255 inside
asdm location MorePayServer 255.255.255.255 inside
asdm location ServerVlan 255.255.255.0 inside
asdm location Vlan59 255.255.255.0 inside
asdm location InternalDownloadServer 255.255.255.255 inside
asdm location DDSInternal5 255.255.0.0 inside
asdm location DDSInternal4 255.255.255.0 inside
asdm location DDSInternal3 255.255.255.0 inside
asdm location DDSInternal2 255.255.255.0 inside
asdm location DDSInternal1 255.255.255.0 inside
asdm location DDSInternal6 255.255.255.0 inside
asdm location DDS_NAT_Src_Pool 255.255.255.240 inside
no asdm history enable
0
Comment
Question by:TSG_Users
  • 2
3 Comments
 
LVL 17

Accepted Solution

by:
Kvistofta earned 500 total points
ID: 33683780
You need to do policy nat for the outbound VPN-tunnel.

For traffic destined for 10.255.255.0/24 and 10.253.0.0/16 sourced from 10.10.0.0/16 you need to change the source to 10.120.15.0/28, right?

Either you hide all your inside host behind one ip, but that will only allow outbound traffic. Like:
nat (inside) 99 access-list NAT-VPN
global (outside) 99 10.120.15.5.
access-l NAT-VPN ext permit ip 10.10.0.0 255.255.0.0 10.255.255.0 255.255.255.0
access-l NAT-VPN ext permit ip 10.10.0.0 255.255.0.0 10.253.0.0 255.255.0.0

Or you do a one-to-on policy nat, which require one static outside IP per inside host. Like:
10.120.15.1 = 10.10.0.1
10.120.15.2= 10.10.0.2
10.120.15.3 = 10.10.0.3

Then you do something like:
static (inside,outside) 10.120.15.1 access-l NAT-1
access-l NAT-1 ext permit ip host 10.10.0.1 10.255.255.0 255.255.255.0
access-l NAT-1 ext permit ip host 10.10.0.1 10.253.0.0 255.255.0.0
!
static (inside,outside) 10.120.15.2 access-l NAT-2
access-l NAT-1 ext permit ip host 10.10.0.2 10.255.255.0 255.255.255.0
access-l NAT-1 ext permit ip host 10.10.0.2 10.253.0.0 255.255.0.0
!
static (inside,outside) 10.120.15.3 access-l NAT-3
access-l NAT-1 ext permit ip host 10.10.0.3 10.255.255.0 255.255.255.0
access-l NAT-1 ext permit ip host 10.10.0.3 10.253.0.0 255.255.0.0

/Kvistofta






I need to be able to get traffic from local VLAN's (10.10.0.0/16) to various networks over a VPN (10.255.255.0/24, 10.253.0.0/16) but my local source address range has to 10.120.15.0/28 for the VPN.
0
 
LVL 1

Author Comment

by:TSG_Users
ID: 33684234
Option one sounds like a plan, I'll give it a bash tomorrow afternoon.
0
 
LVL 1

Author Comment

by:TSG_Users
ID: 33692196
Worked a treat, 500 points to that Expert!

It really is quite straightforward when you break it down into each step, I thought it might have to be some kind of NAT configuration but I was thinking more some kind of static NAT.

Thanks.
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
Let’s list some of the technologies that enable smooth teleworking. 
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now