• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 709
  • Last Modified:

Out of office server unavailable Exchange 2007

OOF on some of the client computers are working and some not.  For example, on my machine and on the Exchange server itself whenever I clicked on the Automatic Replies button it came back with server unavailable message.

I am very new to Exchange 2007 so please provide a detailed instruction on how can I go about checking, comparing the setup on the working machine vs not working machine and fixing this problem.

Thank you,

  • 4
  • 4
  • 2
  • +1
3 Solutions
If the clients are Outlook 2k7
- we need to check if the exchange autodiscover is working fine or not
Using the "Test email autoconfiguration window"

On the failing machines:
are they connecting to exchange from LAN or WAN
- check if they having any proxy-server configuration in the IExplore settings
we need to collect the results and log tab details for the working and failing users to proceed further.

Note: Please do mentioned if the affected  users can directly communicate to the CAS server or not?
If yes, are they domain-joined desktops?
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

try going into owa and options to update oof
outlook 2007 and later clients attempt to use exchange web services for oof, and your configuration might need adjusted
Wayne88Author Commented:
Hi Guys,

Thanks for the quick reply.  I am connecting Outlook inside the LAN so I need a way to test it internally inside the LAN.  We won't bother with external use for now.

Can you clarify how can I check if the users can directly communicate to the CAS server or not?

right-ctrl  + right click on the outlook icon in the task bar
select test automatic email configuration
remove guessamrt check boxes and test

also browse to the url from
get-webservicesvirtualdirectory | fl internalurl
Wayne88Author Commented:
I rant he test and it failed the autodiscover so I did more research and readings.  When I ran "Get-WebServicesVirtualDirectory | fl" this is what I got.....maybe you can steer me in the right direction with this because I am not sure if the internal URL is correct or not. Shouldn't it be the machine name and how can I change it?

server name was changed to SERVER and domain name was changed to DOMAIN.  Thanks.

 Full list of cmdlets:          get-command
 Only Exchange cmdlets:         get-excommand
 Cmdlets for a specific role:   get-help -role *UM* or *Mailbox*
 Get general help:              help
 Get help for a cmdlet:         help <cmdlet-name> or <cmdlet-name> -?
 Show quick reference guide:    quickref
 Exchange team blog:            get-exblog
 Show full output for a cmd:    <cmd> | format-list

Tip of the day #76:

Do you want to see everything that occurs when you run a command? Include the Ve
rbose parameter with the command. This parameter instructs the Exchange Manageme
nt Shell to display detailed information about each action that the server takes
 to complete the command. This information can be useful in troubleshooting.

[PS] C:\Windows\System32>Get-WebServicesVirtualDirectory | fl

InternalNLBBypassUrl          : https://SERVER.DOMAIN.local/ews/exchan
Name                          : EWS (SBS Web Applications)
InternalAuthenticationMethods : {Basic, Ntlm, WindowsIntegrated}
ExternalAuthenticationMethods : {Basic, Ntlm, WindowsIntegrated}
BasicAuthentication           : True
DigestAuthentication          : False
WindowsAuthentication         : True
MetabasePath                  : IIS://SERVER.DOMAIN.local/W3SVC/3/ROOT
Path                          : C:\Program Files\Microsoft\Exchange Server\Clie
Server                        : SERVER
InternalUrl                   : https://remote.DOMAIN.com/EWS/Exchange.asmx
ExternalUrl                   : https://remote.DOMAIN.com/EWS/Exchange.asmx
AdminDisplayName              :
ExchangeVersion               : 0.1 (8.0.535.0)
DistinguishedName             : CN=EWS (SBS Web Applications),CN=HTTP,CN=Protoc
                                ols,CN=SERVER,CN=Servers,CN=Exchange Admin
                                istrative Group (FYDIBOHF23SPDLT),CN=Administra
                                tive Groups,CN=First Organization,CN=Microsoft
Identity                      : SERVER\EWS (SBS Web Applications)
Guid                          : dd395a5b-4d8b-4b40-9663-90d3d2842610
ObjectCategory                : DOMAIN.local/Configuration/Schema/ms-Exch-W
ObjectClass                   : {top, msExchVirtualDirectory, msExchWebServices
WhenChanged                   : 03/09/2010 12:41:47 PM
WhenCreated                   : 03/09/2010 2:28:04 PM
OriginatingServer             : SERVER.DOMAIN.local
IsValid                       : True

[PS] C:\Windows\System32>Get-ClientAccessServer | Select Name, *Internal* | fl

Name                           : SERVER
AutoDiscoverServiceInternalUri : https://remote.DOMAIN.com/Autodiscover/Aut

[PS] C:\Windows\System32>Get-ClientAccessServer | Select Name, *Internal* | fl

Name                           : SERVER
AutoDiscoverServiceInternalUri : https://remote.DOMAIN.com/Autodiscover/Aut

[PS] C:\Windows\System32>
Wayne88Author Commented:
The strange thing is that when I tried it on my workstation, the OOF was accessible after a reboot then I would close Outlook, wait for a few minutes then restart Outlook.  Then when I clicked on the Automatic Replies again it is stating that the server is unavailable.  Not sure why it worked after the workstation was restarted and initial Outlook launch but not thereafter.
Make sure remote.domain.com resolves to an internal ip address and your certificate contains that fqdn

Also verify windows authentication is enabled on the web services vdir
OOF not working

Please check the following steps mentioned below:-

Autodiscover = Basic + Windows Integrated + SSL Forced == Disable - Kernel Mode Authentication.
OAB= Windows Integrated = Disable - Kernel Mode Authentication.
EWS= Windows Integrated = Disable - Kernel Mode Authentication + SSL forced.

Follow the kb-940726, and run the following command on the server.

Set-ClientAccessServer -Identity CAS_Server_Name -AutodiscoverServiceInternalUri https://mail.contoso.com/autodiscover/autodiscover.xml 

Set-WebServicesVirtualDirectory -Identity "CAS_Server_Name\EWS (Default Web Site)" -InternalUrl https://mail.contoso.com/ews/exchange.asmx

Set-OABVirtualDirectory -Identity "CAS_Server_name\oab (Default Web Site)" -InternalUrl https://mail.contoso.com/oab

Please run the following command in the management shell:-

test-outlookWebserivces | fl and see the result. If you get 401 Unauthorized please follow the below link and restart the server.

DisableLoopbackcheck registry.
key as per the article <http://support.microsoft.com/kb/896861>.

Then perform "SetSPN -a http/(Exchange server FQDN) (Exchange server name)"

Check the HTTP keep alive in IIS 7 in the following place:-
HTTP response headers on Default WebSite == set common headers.

If still the issue persists, please follow this steps:-

Delete and recreate the Autodiscover/ EWS Virtual Directories.
Remove-AutodiscoverVirtualDirectory -identity "CAS server name\Autodiscover (Default Web Site)"
Remove-WebservicesVirtualDirectory -identity "CAS server name\EWS (Default Web Site)"

And follow the kb-940726 again to set the InternalUri.
Perform IISreset.

And also please check whether you have 3.5 .netFramework, if yes please download and install the following hotfix.
KB- 958934

And Run Test EmailAutoconfiguration  from outlook 2007 client, and please select only Autodiscover. Remove Guessmart and Secure Guess mart.

Please check out these steps and revert back if the issue persists.
Wayne88Author Commented:
Thanks v_9mhdrf,

I will check out your recommendation this weekend.  For the mean time I hardcoded the autodiscover address into the host file on my workstation and so far it has been working.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

  • 4
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now