Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

"choose the program you want to use to open this file" when opening hyperlinks in Outlook 2007

Posted on 2010-09-15
8
815 Views
Last Modified: 2012-05-10
I have already selected IE and checked the box to "Always use the selected program to open this kind of file", multiple times.

It hasn't helped. It still wants me to choose a program every time.

Windows 7 Professional, 64 bit.
0
Comment
Question by:itentive
8 Comments
 
LVL 3

Expert Comment

by:Gilesmp
ID: 33683910
Is Internet Explorer set as your default browser?
0
 

Author Comment

by:itentive
ID: 33684018
Yes
0
 
LVL 14

Expert Comment

by:athomsfere
ID: 33684118
Did you at one point have another browser set as the default?

My guess is a bad reg key.

Have you tried it from another profile same machine? That should at least verify if its HKEY Current user, or machine wide.
0
Networking for the Cloud Era

Join Microsoft and Riverbed for a discussion and demonstration of enhancements to SteelConnect:
-One-click orchestration and cloud connectivity in Azure environments
-Tight integration of SD-WAN and WAN optimization capabilities
-Scalability and resiliency equal to a data center

 
LVL 3

Expert Comment

by:Gilesmp
ID: 33684157
Ok, can you try the following:

Click Start, select Control Panel
Cick Programs
Underneath Default Programs, select Set your default programs
In the Programs list, highlight Internet Explorer and click Choose Defaults for this program
Check that they are all selected, if not Select All and then Save

If that doesn't work, try running this batch file to restore the IE associations (http://www.local-it-guy.com/tips/restrictions.html and download the ZIP file)
0
 

Author Comment

by:itentive
ID: 33684556
@athomsfere:  It's machine-wide. Happens on multiple user accounts.

@gilesmp: The default programs are already correct, and I tried the batch file.  Same problem
0
 
LVL 5

Accepted Solution

by:
StefanKamp earned 250 total points
ID: 33685528
You proably have uninstalled Google Chrome:
Read this, it will solve the issue:

http://www.google.com/support/forum/p/Chrome/thread?tid=6223bc3b0294b96a&hl=en

Hope this helps.

Br. Stefan
0
 

Author Comment

by:itentive
ID: 33735383
@Stefankamp: I gave those registry changes a shot. No go.
0
 
LVL 3

Assisted Solution

by:Gilesmp
Gilesmp earned 250 total points
ID: 33735417
Did you have Chrome installed before.  I have seen this error before and the user reinstalled Chrome, set that as default, set IE as default again and all was back to normal.
0

Featured Post

Networking for the Cloud Era

Join Microsoft and Riverbed for a discussion and demonstration of enhancements to SteelConnect:
-One-click orchestration and cloud connectivity in Azure environments
-Tight integration of SD-WAN and WAN optimization capabilities
-Scalability and resiliency equal to a data center

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

INTRODUCTION The purpose of this document is to demonstrate the Installation and configuration of the Data Protection Manager product. Note that this demonstration was prepared on the basis of Windows OS is 2008 R2 and DPM 2010. DATA PROTECTI…
Outlook Free & Paid Tools
Learn how to create and modify your own paragraph styles in Microsoft Word. This can be helpful when wanting to make consistently referenced styles throughout a document or template.
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question