Solved

Make "This is a private computer" the default in RDWeb.

Posted on 2010-09-15
8
5,458 Views
Last Modified: 2013-05-29
I’m setting up RDWeb in Windows 2008 R2 remote desktop services.  On the default web page where it gives the user a choice between “Public” or “Private” computer, is there a way to make the “This is a private computer” the default, or remove the choices and make it the default?
0
Comment
Question by:kfasick
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
8 Comments
 
LVL 30

Expert Comment

by:Brad Howe
ID: 33686465
Hi,
1. Open c:\windows\Web\RDWeb\Pages\en-us\Login.aspx in notepad
2. Search for "checked"
3.  Modify the radio defaults for rdoPlbc to be rdoPrvt.
Sample excerpt from Login.aspx
    const string L_PublicLabel_Text = "This is a public or shared computer";
    const string L_PrivateLabel_Text = "This is a private computer";
.......
       <label><input id="rdoPblc" type="radio" name="MachineType" value="public" class="rdo" onclick="onClickSecurity()" /></label>

                                <label><input id="rdoPrvt" type="radio" name="MachineType" value="private" class="rdo" onclick="onClickSecurity()"  checked /></label>
 
 Cheers, Hades666
0
 

Author Comment

by:kfasick
ID: 33686876
Worked great.  Is there any way to remove the choices and just set it to private?
0
 
LVL 30

Expert Comment

by:Brad Howe
ID: 33686982
Remove the input and label from the page OR comment it out with <!-- and end it with --> -Hades666
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 30

Expert Comment

by:Brad Howe
ID: 33687207
Sorry, I was on the road.
Here you go. I wouldn't remove them, but make one the DEFAULT and then just hide them like such.
Login.aspx
<input id="rdoPblc" type="radio" name="MachineType" value="public" class="rdo" onclick="onClickSecurity()" visible="False" />

<label><input id="rdoPrvt" type="radio" name="MachineType" value="private" class="rdo" onclick="onClickSecurity()" checked visible="False" /></label>  

Cheers, Hades666
0
 

Author Comment

by:kfasick
ID: 33693912
I added the visible="False", but they are still displayed.
0
 
LVL 30

Expert Comment

by:Brad Howe
ID: 33694408
Yes,
That parameter is for a ASP RadioButton 2.0 object. This happens because it is an INPUT and not an asp:radiobutton object.
Syntax <INPUT> Attribute Specifications TYPE=[ text | password | checkbox | radio | submit | reset | file | hidden | image | button ] (type of input)
  NAME=CDATA (key in submitted form)
  VALUE=CDATA (value of input)
  CHECKED (check radio button or checkbox)
  SIZE=CDATA (suggested number of characters for text input)
  MAXLENGTH=Number (maximum number of characters for text input)
  SRC=URI (source for image)
  ALT=CDATA (alternate text for image input)
  USEMAP=URI (client-side image map)
  ISMAP (server-side image map)
  ALIGN=[ top | middle | bottom | left | right ] (alignment of image input)
  DISABLED (disable element)
  READONLY (prevent changes)
  ACCEPT=ContentTypes (media types for file upload)
  ACCESSKEY=Character (shortcut key)
  TABINDEX=Number (position in tabbing order)
  ONFOCUS=Script (element received focus)
  ONBLUR=Script (element lost focus)
  ONSELECT=Script (element text selected)
  ONCHANGE=Script (element value changed)

To get around this, you would need to use javascript to hide it.
-Hades666
0
 
LVL 30

Accepted Solution

by:
Brad Howe earned 500 total points
ID: 33694449
Hi, Actually, change visible="False" to style="display:none;" ... I haven't used INPUTS in ages.
Cheers, Hades666
0
 
LVL 1

Expert Comment

by:oneprospect
ID: 39205685
This no longer seems to work in Server 2012. XSL/XML requires is be checked="checked" but that still does not make it the default.

Searched everywhere in all .xsl and .aspx files, but can't find what is making "Public" the default.

Any thoughts?
0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scenario:  You do full backups to a internal hard drive in either product (SBS or Server 2008).  All goes well for a very long time.  One day, backups begin to fail with a message that the disk is full.  Your disk contains many, many more backups th…
If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question