Solved

Exchange error: c104173b - Database is corrupt

Posted on 2010-09-15
10
3,950 Views
Last Modified: 2012-05-10
This morning, exchange was down when I came in. Here is the history:

Win 2003 SP2, Exchange 2003, approx 40 users.
Backup Exec 12.5, sp2
Backup Exec 12.5 - Backup of exchange ran @ 11:40 PM last night, I'm not sure if data is corrupt. 8AM today, mailstore was not mounted. Error C104173B is displayed when trying to mount mailstore in ESM. There is over 200 gig of free disk space on all drives.

File Sizes
Priv1.stm 20 gig
Priv1.edb 17.5 gig
pub1.edb 63 meg

I think esutil should be run. How do I run it in report only mode to further investigate before changeing the file?

How should I proceed overall?
0
Comment
Question by:Tony Giangreco
10 Comments
 
LVL 32

Expert Comment

by:endital1097
ID: 33684140
run an integrity check
http://technet.microsoft.com/en-us/library/aa998361(EXCHG.80).aspx

first option should be a restore before running the repair (eseutil /p)
0
 
LVL 10

Expert Comment

by:dhruvarajp
ID: 33684200
yes,, and if at all  you find curruptions it is recomended you restore from the full back if you have  and not repair the database as this can render database useless
and what you can do is do the roll forward restore to avoid data loss
0
 
LVL 25

Author Comment

by:Tony Giangreco
ID: 33684426
I ran eseutil /g and received this message:
operation terminated with error -1031 <jet_FileAccessDenied. Cannot access file. The file is locked or in use after 14 secs.

I'm logged in as the server admin.
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33684458
is the database mounted? you can only run eseutil when the database is offline

which database generated the event?
0
 
LVL 25

Author Comment

by:Tony Giangreco
ID: 33684502
Yes, the db is not mounted. Should I stop the exch services?
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 32

Expert Comment

by:endital1097
ID: 33684626
you just need to dismount the affected database
0
 
LVL 25

Author Comment

by:Tony Giangreco
ID: 33684673
The mailstore is not mounted and wil not mount.
I just ram eseutil /g to check integrity. It displayed a message stating I should abort due to logs not being run. then in the cmd box, it says the db was not shutdown properly and is dirty. Recovery must run first.

How do I safely run recovery without chamging the current db?
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33684683
eseutil /r
0
 
LVL 20

Accepted Solution

by:
Satya Pathak earned 250 total points
ID: 33685927
I would Suggest you if you have a good backup , you can use it.
another options as per error code -1031 you can ran eseutil/p and /d and isinteg.
0
 
LVL 32

Assisted Solution

by:endital1097
endital1097 earned 250 total points
ID: 33687094
Did you run the soft recovery with success? Restore from backup if possible before eseutil/ p
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now