Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1395
  • Last Modified:

Linksys WRT160N DHCP Problem

I have a Linksys WRT160N Wireless Router/Access Point that I am trying to use behind a Watchguard Firebox firewall.  The Watchguard Firebox acts as a DHCP server handing out addresses to a network for hardwired network items such as a network printer, desktop PC and a NAS device and is set to give addresses of xx.xx.xx.100 and below.  I want to have the WRT160N to act as a DHCP on the same network for my wireless laptop and limit it to handing out addresses beginning at xx.xx.xx.190.  The problem I am having is that when I assign the WRT160's device IP address to the same network (i.e. xx.xx.xx.160) and try to have it act as a DHCP server, it will assign an IP to the wireless laptop OK, but within a few seconds, I lose all connectivity to the internet on the wireless laptop.  The WRT160 works fine as a DHCP server as long as I leave it on a seperate netork (i.e default of 192.168.1.1 or any other) and the problem only occurs when I try to  make it work on the same network as the other devices.  The WRT160N is a version 2 with firmware version 3.04.  Any ideas?
0
gboo19
Asked:
gboo19
1 Solution
 
CynepMeHCommented:
Make sure both DHCP scopes are configured with the same parameters - e.g. DNS server, default gateway and there's no address overlap. Keep in mind that whichever DHCP server responds first, that's the one that's going to hand out address. Also confirm your lease times are not too short, resulting in client having to renew lease frequently and possibly having another DHCP server hand out the lease.

When you run IPconfig /all - ocnfirm that a)the dhcp server you expect is the one that handed out address b)dns settings are correct c)default gateway and subnet mask are correct e)lease duration is something reasonable - say 4 hours or more.

My recommendation though would be to stick to a single DHCP server in a setup like yours.
0
 
ChickensaurCommented:
It has been my experience that this is not possible.  I may be wrong but what happens is each DHCP "server" tries to take control of the addresses and one eventually fails.  
0
 
StefanKampCommented:
It's technically impossible to run more than 1 DHCP server in one subnet. In your setup, it's quite variabel who will hand out the IP address, as it then depends on which DHCP server is the most quickest of both, then it may receive the answer from the other DHCP server as well (but a few secs later), causing your networkadapter confused.

I believe you only have to options:
1. shutdown the DHCP server on 1 device --or--
2. connect the Watchguard to the wanport of the WRT160 instead of LAN, enable DHCP on the WRT160 handing out addresses in another subnet
0
 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

 
CynepMeHCommented:
Not to be a techno-snob, but it IS possible to run multiple DHCP servers on same subnet, you just have to configure it properly. Please see (DHCP 80/20):

http://technet.microsoft.com/en-us/library/cc958936.aspx

0
 
gboo19Author Commented:
Thanks to all for the responses.  I am somewhat of a newbie using multiple routers, but I now understand that the issue likely is trying to run 2 DHCP servers on the same subnet.  The wireless is "behind" the Watchguard firewall and the Watchguard is the primary gateway to the internet.  If I disable the DHCP server on the wireless, make the IP of the wireless static on the network I want to use, will the Watchguard DHCP server pass IP addresses through the wireless to assign them to my laptop?  The laptop IP doesn't have to be 190+.
0
 
gboo19Author Commented:
Thanks CynepMeH.  I'll try that tonight when I'm home.
0
 
CynepMeHCommented:
Yes. Configure as follows:

1. Provide static IP to your Linksys, set default gateway pointed to watchguard, same subnet mask as watchguard (I suspect 255.255.255.0). Turn off DHCP on it.

2. Unless you have specific IP addresses for DNS servers that you have to use, your DNS should be pointed to your Watchguard as well.

3. On Watchguard, make sure DHCP scope is set up properly as well - e.g. it picks up your ISP's DNS parameters and hands them out to your clients, which seems to be the case.

When your client connects to Linksys, it will send a dhcp broadcast and your watchguard should reply with an address to be assigned to wifi client(s).

cheers.
0
 
gboo19Author Commented:
Thanks to all for the ideas.  Seems as though I was fighting a losing battle though.  Tried to setup using CynepMeH's last suggestion with no luck.  Ultimately, lost all connectivity to internet no matter what I tried.  Tried multiple nights to no avail.  Wireless wouldn't even connect when I tried connecting direct to DSL modem without other firewall.  Seems like the wireless router was going/went bad.  Got a new one today and tried CynepMeH's suggestion and WA-LA... everything works fine.  Thanks!
0

Featured Post

Microsoft Certification Exam 74-409

VeeamĀ® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now