We help IT Professionals succeed at work.

Remote Desktop Error

ComtechNC
ComtechNC asked
on
1,080 Views
Last Modified: 2012-05-10
I have just recently installed a new network for one of our customers. They are running Server2008 R2 with Hyper V. This server runs 2 Virtual Machines, one is a Domain Controller/ Mail Server/ Print Server and File Server. The second one is a Application server only. The Domain controller is a Windows Server 2008 R2 running Kerio Mail server. Everything runs like it is supposed to. The Application server has Windows Server 2003 R2 and is part of the domain. I have Remote Desktop Enabled with the Administrator having access. When trying to Remote into the Application server via RDP we get an error message

"The computer can't connect to the Remote Computer.
The connection was lost due to a network error. Try connecting again. If the problem continues, contact your network administrator or technical support."

I have tried from a Windows XP Machine, Windows 7, the Host and the Domain Controller. All of them do the exact same thing. When I go back to the Application Server It has an Error in the System Event Log.

" Source TermDD Event ID: 50
Description:
The RDP protocol component "DATA ENCRYPTION" detected an error in the protocol stream and has disconnected the client."

I have tried the suggested stuff at EventID and seen a couple post here about people having this problem in different scenarios. I am hoping someone will be able to help.

Thanks for you help,
Mike
Comment
Watch Question

IT Admin
CERTIFIED EXPERT
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
Try what kadadi_v offered, it worked for me in the past

Also check http://support.microsoft.com/kb/257894

George SasIT Engineer

Commented:
Can you telnet on port 3389 on the machine ?
From another machine try to telnet to it on 3389
Go to Administrative Toos , Remote Desktop Services , and select "Remote Desktop Session Host Configuration".
Check the encryption level.


rdp.png

Author

Commented:
Thanks everyone for the replies. It appears that the registry edit helped.

Mike
George SasIT Engineer

Commented:
Doh ... sorry , I saw Windows 2008 :) good you solved it.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.