Solved

prevent users from changing DNS server settings on XP or block DNS from PIX

Posted on 2010-09-15
13
1,448 Views
Last Modified: 2012-05-10
Hi, I want to use opendns.com and want to prevent windows XP users from chaning their dns settings after I make opendns their dns. Or is there a way in PIX to block or catch all DNS traffic except for the servers that belong to opendns?

Thanks,

Art
0
Comment
Question by:kaosmadness
  • 3
  • 3
  • 2
  • +3
13 Comments
 
LVL 5

Expert Comment

by:Ioannis_Avgeros
ID: 33686478
Hi,

simply denying them admin rights on their local computers will do that for you.
0
 
LVL 5

Accepted Solution

by:
Ioannis_Avgeros earned 64 total points
ID: 33686484
As for PIX just create an access list:

check here: http://www.tek-tips.com/viewthread.cfm?qid=742313&page=214 
0
 

Author Comment

by:kaosmadness
ID: 33686499
Thanks Ioannis. Sorry i should have clarified, we run software that requires the user logged in to have admin rights. Is there a way to change just that setting or filtering dns from PIX?
0
3 Use Cases for Connected Systems

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, testing some more, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us.

 
LVL 33

Assisted Solution

by:MikeKane
MikeKane earned 62 total points
ID: 33686543
The link that Ionnis gave you is the correct answer.   Allows port 53 for opendns, then block for all others.   Forces the users to use opendns or they get no resolution.
0
 

Author Comment

by:kaosmadness
ID: 33686880
Great! I will accept that as a solution! But is there any way to have all traffic redirected at the pix so I dont have to change DNS servers in all the end users computer? A lot of them have a static IP so I would have to go change all of them since changing it in DHCP server wont affect them.
0
 
LVL 10

Assisted Solution

by:wdurrett
wdurrett earned 62 total points
ID: 33686931
Hi Kaos.

I assume that you are not in a domain environment if you are setting DNS servers on the actually machines?

If you are, there is a group policy that will lock DNS.

Also, rather than creating an access list only, you can use Bi-Directional NAT with Port Forwarding to force every DNS request to OpenDNS - regardless of the server set at the computer level.  So if a user changes the DNS server on the workstation, they will still be using OpenDNS.  This will allow for name resolution to the servers you want while keeping the helpdesk line quiet.  Read more here:
http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_tech_note09186a0080094aad.shtml

0
 
LVL 5

Expert Comment

by:Ioannis_Avgeros
ID: 33687061
Why don't you use a DHCP server instead of setting IP Addresses locally? It would make your life a lot easier.
0
 
LVL 9

Assisted Solution

by:CLoz
CLoz earned 62 total points
ID: 33688730
If you wanted to you could configure a 'reverse' port redirect on the PIX to redirect all outbound port 53 traffic to the OpenDNS.com server. So even if a user changes their DNS, their request will always go to the OpenDNS name server.  
Use static (outside, inside) vs. static (inside,outside)
0
 

Author Comment

by:kaosmadness
ID: 33696752
Here you go!  Thanks again, we use an ATT managed internet service, is it possible they are blocking ports in their managed router?
PIX Version 6.3(5)
interface ethernet0 10baset
interface ethernet1 10baset
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ---- encrypted
passwd -----
hostname cisco-pix
domain-name sheraton.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names        
access-list 100 permit icmp any any
access-list 100 permit tcp any any eq 1433
access-list 100 permit tcp any any eq 1434
access-list 100 permit udp any any eq 1434
access-list 100 permit udp any any eq 1433
access-list any permit tcp any any eq 1433
access-list any permit udp any any eq 1434
access-list 300 permit ip any any
pager lines 20
logging on    
logging buffered warnings
mtu outside 1500
mtu inside 1500
ip address outside XX.XX.XX.X 255.255.255.240
ip address inside 10.63.104.11 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
pdm location 10.63.104.253 255.255.255.255 inside
pdm location 10.63.104.0 255.255.255.0 inside
pdm location 10.63.104.227 255.255.255.255 inside
pdm location 12.120.XX.XX 255.255.255.255 outside
pdm logging debugging 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group 300 in interface inside
route outside 0.0.0.0 0.0.0.0 12.68.113.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 10.63.104.253 255.255.255.255 inside
http 10.63.104.227 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh 10.63.104.253 255.255.255.255 inside
ssh 10.63.104.0 255.255.255.0 inside
ssh timeout 60
console timeout 0
username ---------
terminal width 80
Cryptochecksum:33b081b2d820ff6c31e4d01d79490fc1
0
 
LVL 33

Expert Comment

by:MikeKane
ID: 34176036
I would suggest a 4 way split since we all gave good suggestions.
0
 
LVL 59

Expert Comment

by:LeeTutor
ID: 34228641
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
VMware 6.0 3 68
Cisco WLAN 5520 licensing 10 32
DNS Server Service Missing on Domain Controller Server 2012 R2 19 28
Cisco 3800 series and WISM2 1 13
There have been a lot of times when we have seen the need to enter a large number of DNS entries in a forward lookup zone. The standard procedure would be to launch the DNS Manager console, create the Zone and start adding new hosts using the New…
This past year has been one of great growth and performance for OnPage. We have added many features and integrations to the product, making 2016 an awesome year. We see these steps forward as the basis for future growth.
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

815 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now