• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 605
  • Last Modified:

Switching routers and server is not resolving

Inherited a small network that uses Untangle box for router/firewall (192.168.1.1). Been freezing up, time to replace, so am installing a Sonicwall TZ100. My DHCP/DNS Server, though is my windows server 2008 box. Like typical, its dns server is 127.0.0.1 and a forwarder of 192.168.1.1..
However, when I swap the Untangle for the Sonicwall (gave same ip), the Windows server will not resolve domains.... as soon as I plug back in the Untanngle, it resolves. I can resolve directly from the sonicwall...so what step am I missing? Thx for help..
0
xav1963
Asked:
xav1963
  • 13
  • 12
1 Solution
 
vanbarsounCommented:
The windows server DNS server setting should be set to its own actual IP, NOT 127.0.0.1
0
 
xav1963Author Commented:
vanbarsoun .... 127.0.0.1 has always worked for me... but I changed it to local ip... so far no difference in resolving....
0
 
vanbarsounCommented:
Have you checked the Sonicwall to see if it can resolve domains? I believe it should be in the System>Diagnostics>then PING tool
0
On-Demand: Securing Your Wi-Fi for Summer Travel

Traveling this summer?Check out our on-demand webinar to learn about the importance of Wi-Fi security and 3 easy measures you can start taking immediately to protect your private data while using public Wi-Fi. Follow us today to learn more!

 
xav1963Author Commented:
yes it resolves fine....
0
 
xav1963Author Commented:
Van.... let me retract that statement... in sonicwall>diagnostics... I can easily do domain lookups...
but it will not ping the same hosts...what do I need to open on the sonicwall?
0
 
vanbarsounCommented:
Run a "tracert www.google.com" or any other domain from your Windows server and see where's it's failing.
0
 
vanbarsounCommented:
It's OK if the Sonicwall is not getting a ping response, as long as it's able to resolve the domain name to an IP address.
0
 
vanbarsounCommented:
Check your Sonicwall Network>DNS setting and you'll probably find your answer there. It should point to either your ISP's DNS servers or a reliable DNS servicer like opendns.org (208.67.220.220 and 208.67.222.222).
0
 
xav1963Author Commented:
I can connect a laptop to the sonicwall and have internet... so wouldn't it be something on the windows server?
0
 
xav1963Author Commented:
yet when I add sonicwall to the network and do a tracert from windows server, I get "unable to find target system"...
0
 
vanbarsounCommented:
Sounds like it. Have you run the tracert command on the windows server? Can you send a screenshot of the DNS forwarder setup?
0
 
xav1963Author Commented:
ok..give me a minute to get those... one diferrence I have found...
if I enable dhcp server on sonicwall, it will provide my isp dns servers and laptop resolves fine...
if I put in static and list its local ip (192.168.1.1) as dns server, wont' resolve...
which that is how windows server dhcp is setup... dns forwarder is 192.168.1.1

0
 
vanbarsounCommented:
That makes sense, so have you checked the actual DNS settings the Sonicwall itself is using in the Network>DNS section? Because once DNS queries get passed off to the Sonicwall, whether it's your Windows server or laptop making the request, the Sonicwall is going to look at its own DNS setup and go from there, and that's where it seems to be failing.
0
 
xav1963Author Commented:
I added the isp dns servers to the windows server dns forwarders list... with the 192.168.1.1 beig in first place...and now I have internet... but why? I shouldn't have to do that... it works fine with just the 1 forwarder when I use the Untangle box...any thoughts....
0
 
vanbarsounCommented:
Still waiting on the Network>DNS settings which might answer your question.
0
 
xav1963Author Commented:
ok...I have compared the dns settings on untangle and sonicwall and are identical... only difference is that our isp is timewarner with 1 static ip... on the untangle, it still set to dynamic wan while on the sonicwall, I put the info in as static....
what do you want me to send a screenshot of again?
0
 
vanbarsounCommented:
Still waiting on the Network>DNS settings which might answer your question.
0
 
xav1963Author Commented:
0
 
vanbarsounCommented:
ok, need 2 more: on the sonicwall go to Network>DNS and send a screenshot of that. And on your windows server need a screenshot of the DNS forwarding settings of the forward lookup zone in question (this will override the settings you've provided in the screenshot per the note in the bottom of the screenshot).
0
 
xav1963Author Commented:
not sure if this is what you want...sorry....
local-domain-ns.png
sonicwall-dns.png
0
 
xav1963Author Commented:
Here is my nslookup now from the server... takes a little while to kick in and resolve... can I fix that?
nslookup.png
0
 
vanbarsounCommented:
Check the Conditional Forwarders in your Windows DNS console (second last node in your screenshot) to make sure nothing is configured there.
0
 
xav1963Author Commented:
there are no items in the conditional forwarders...
0
 
vanbarsounCommented:
I just tried to simulate your environment, sort of, and if I point my DNS to the sonicwall resolution fails also. At this point I'm not sure if it's a Sonicwall issue or if this is by design, but since ultimately your ISP's DNS servers are going to resolve things I would remove your 192.168.1.1 entry from your forwarders list, leaving the 2 other ISP entries,  and it should work fine.
0
 
xav1963Author Commented:
ok....works for me now...later on I might open a ticket with Sonicwall and see what they say but for now...this works fine...thx for help...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 13
  • 12
Tackle projects and never again get stuck behind a technical roadblock.
Join Now