Solved

Visual Studio's "F8 Step Into" triggers my laptop's Lock-the-screen function

Posted on 2010-09-15
8
497 Views
Last Modified: 2013-11-26
How can I get Visual Studio's "F8 Step Into" to work on my laptop? When I am in Visual Studio's IDE and have a VB.NET project open, every time I hit F8, my laptop triggers its Lock-the-screen function instead of letting Visual Studio see the F8.
0
Comment
Question by:lee88
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
  • 2
8 Comments
 
LVL 70

Expert Comment

by:Éric Moreau
ID: 33687832
you may have to press Fn-F8
0
 

Author Comment

by:lee88
ID: 33687865
Thanks for the try, but Fn-F8 toggles my video inputs {CRT, LCD, ...}
0
 
LVL 9

Expert Comment

by:TonyReba
ID: 33687982
why dont you just use your mouse and right click on the part youu want to step into.??   alternatively open windows virtual keyboard and press f8 in theere
0
How Do You Stack Up Against Your Peers?

With today’s modern enterprise so dependent on digital infrastructures, the impact of major incidents has increased dramatically. Grab the report now to gain insight into how your organization ranks against your peers and learn best-in-class strategies to resolve incidents.

 

Author Comment

by:lee88
ID: 33688028
how do you open windws virtual keyboard?
0
 
LVL 9

Expert Comment

by:TonyReba
ID: 33688046
Under accessories accessibility tools
0
 

Author Comment

by:lee88
ID: 33690196
TonyReba:
 - Problem with using my mouse to right click the line I want to step into is that it takes more keystrokes than the Debug | Step Info approach.
 - also, using virtual keyboard and press f8 causes my laptop to lock the screen, just like the physical F8 key does.

So, my problem has not been resolved.
0
 

Author Comment

by:lee88
ID: 33690317
I dont understand this, but it has resolved my immediate problem:
When I go to Tools | Options | Environment | Keyboard,  Debug.StepInto is set to F11 and F11 works.
0
 
LVL 70

Accepted Solution

by:
Éric Moreau earned 500 total points
ID: 33690627
You have the choice of the IDE settings when you install Visual Studio. F8 belongs to the VB settings while F11 belongs to the C# and /or Visual Studio generic settings.
0

Featured Post

The Orion Papers

Are you interested in becoming an AWS Certified Solutions Architect?

Discover a new interactive way of training for the exam.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A basic question.. “What is the Garbage Collector?” The usual answer given back: “Garbage collector is a background thread run by the CLR for freeing up the memory space used by the objects which are no longer used by the program.” I wondered …
Today I had a very interesting conundrum that had to get solved quickly. Needless to say, it wasn't resolved quickly because when we needed it we were very rushed, but as soon as the conference call was over and I took a step back I saw the correct …
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question