Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1000
  • Last Modified:

the auto created ASPX from Silverlight application will not run

Hi,

We used VS2010 to create a silverlight app, and an aspx and html page were being auto generated. The html works fine, but, for unknown reason, the aspx will not run. When we check under IE, it shows
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; Tablet PC 2.0; FDM; InfoPath.3; .NET4.0C; .NET4.0E)
Timestamp: Thu, 16 Sep 2010 03:05:09 UTC


Message: Unhandled Error in Silverlight Application
Code: 2104    
Category: InitializeError      
Message: Could not download the Silverlight application. Check web server settings    

Line: 57
Char: 13
Code: 0
URI:

Can anyone tell us where is the problem please? Thanks.

We are hosted the page @ Windows Server 2008 R2 with IIS 7
0
cybeh
Asked:
cybeh
  • 7
  • 3
1 Solution
 
meispiscesCommented:
What were the steps that you follow to create a silverlight app, the one  that had aspx and html page auto generated?

Thanks
0
 
meispiscesCommented:
Please ignore my previous comment.

I have got your solution. This error comes as you are using Windows Server. For that you need to add MIME types for silverlight which are .xap/.xaml/ .xbap

For more info: http://forums.silverlight.net/forums/p/111126/309207.aspx

Hope this helps!

Thanks

0
 
meispiscesCommented:
See Detail steps to be configured in Windows Server (ie in IIS) from here: http://blog.stronico.com/2009/10/how-to-solve-unhandled-error-in-silverlight-application-code-2104/

thanks!
0
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
Dhanasekaran SengodanCommented:
0
 
meispiscesCommented:
@cybeh: Is your problem resolved? Please comment.

thanks!
0
 
cybehAuthor Commented:
Hi,

Thanks for all the reply. As mentioned, we are using Windows server 2008, IIS7 which silverlight are "reset". But, as extra steps, I still check to make sure all the mime type are there.

And another question would be, if silverlight is not supported, then, most prolly the .html will not run as well? But, seems like the same file with .html were able to host the silverlight application without any issue.

Maybe I overlook some of the suggestion? Please advise.
0
 
meispiscesCommented:
>>> we are using Windows server 2008, IIS7 which silverlight are "reset"?

What do you mean by this?

Plus, if SL is not supported then i guess that .html will run as it has nothing to do with html.

Hope i have resolve your queries.

Thanks!
0
 
cybehAuthor Commented:
Wow.. finally got my issue solved. It's actually nothing to do with the server setting, but, were set the wrong "path" for my silverlight application in my ASPX.

Thanks everyone for the support
0
 
meispiscesCommented:
Happy to see that you have found out the solution. Did the solution worked for you? if not let me knw, as i need to lookout for the same.
thanks. :-)
0
 
cybehAuthor Commented:
Hi,

Just an extra info over here.
1. If the server does not support SL, then, regardless of HTML or ASPX, both will not run.

For my issue, it due to a silly issue
<param name="source" value="ClientBin/myApp.xap"/> <- When the system auto generated, the value was "Bin/myApp.xap", where system can't find the .xap.

0
 
meispiscesCommented:
I guess experts (including me) have invested their time in resolving the issue, hence i think the most deserving expert should be awarded the points.

Rest is upto EE Admin, Moderators & to author.

Thanks!
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 7
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now