• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 578
  • Last Modified:

Setup Exchange 2007 accepted domains incorrectly

Hi - I have setup SBS2008 wrong. The businesses email domain is btinternet.com (this is the first exchange setup I have done where they use a public email domain like this).
I followed my normal procedure and btinternet.com is in the accepted domains in the EMC - now unsurprisingly they cannot email anyone with a btinternet.com email address outside the organisation as Exchange looks for their account internally then bounces the message when it cant find the local account - their mail is delivered via pop connector. Can someone tell me how I can remove the btinternet.com from the accepted domains (I have tried and get the following error: Cannot remove the domain 'btinternet.com' because it is referenced by the proxy address template 'SMTP:%m@btinternet.com'.
Thanks for any help you can give...
0
activateahsd
Asked:
activateahsd
1 Solution
 
Mkris9Commented:
You can't set up a public email domain on your local exchange server - otherwise you'll get the exact same problem. What you'll have to do is to remove the accepted domain (i believe everyone is receiving emails via POP ? ), setup a the default accepted domain with your domain.local address. But create an email address policy that gives all users a btinternet.com address.

Please note that the email addresses for users which is %m@btinternet.com must exist on bt internet's email servers.
0
 
ashaw2009Commented:
OK. The best thing to do in SBS is to go and re-run the "connect to the internet wizard" and the other wizards found in the SBS Management console under admin tools. if you setup SBS wrong form the start then you may have incorrect Remote Web Workplace, Company web and OWA URL's. Just double check these.

Secondly what you need to do is change the recipient policies and accepted domains. You may find that inside the accepted domain policy you have the wrong configuration. See if you can follow the steps in the below website and change the policy settings to be the correct domain:
http://msexchangeteam.com/archive/2006/11/16/431531.aspx
0
 
activateahsdAuthor Commented:
I re ran the 'Setup your Internet address' wizard in SBS2008 - changed the default email domain from btinternet.com to something else, then in EMC was able to add btinternet.com as an accepted domain but as an 'External relay'. This seems to have worked...
Thanks for your help...
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now