check why an exchange 2007 email has not been received

where can i check to see why i have not received an email
A customer told me they had sent me an email but i have not received it
Im using exchange 2007 built in anti spam and had the reject settings at 8.
I have now enabled the quarantine and set it to 6 (not sure if i need a restart for this to take effect)
But need to know why i did not receive this mail
dougdogAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
mcp_jonConnect With a Mentor Commented:
With that level of blocking, 8, message could have been deleted as a False-Positive.

Try to decrease the value and monitor.
0
 
endital1097Commented:
enable verbose logging for your receive connector and monitor for connections from the sender
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
dougdogAuthor Commented:
as i hadnt it enabled is there nothing i can check to apart from that
0
 
endital1097Commented:
you could try the message tracking log
get-messagetrackinglog -server hub -start "9/16/2010" -sender jim@ee.com
0
 
endital1097Commented:
but if the issue is connection related you need to have the logging enabled
0
 
dougdogAuthor Commented:
how would i know if it was classed as spam
0
 
endital1097Commented:
run the get-messagetrackinglog cmdlet with the " | FL" at the end
0
 
dougdogAuthor Commented:
will this show me all blocked messages
0
 
endital1097Commented:
unfortunately i don't have exchange antispam enabled, but if you find one you can updated the command to filter for just blocked
0
 
sunnyc7Commented:
dougdog
Why dont you run get-messagetrackinglog from exchange shell and let us know the results.

Also
let us know if you have a backup MX configured to that of your ISP.

Since the customer didnt get a NDR i am assuming the message was delivered.
0
 
dougdogAuthor Commented:
no trace of it anywhere in that log
0
 
HousammuhannaConnect With a Mentor Commented:
I have  Q,
Why dont you try to disable to AntiSpam for Exchange for about 10 miniuts and do the test
see if you can get the Emial , that mean that its an AntiSpam other wise it will be another problem and we will see what it could be
NOTE: Check evetlog Errors, some time Hub Transport tell why it block this message !!
0
 
dougdogAuthor Commented:
thanks
0
 
mcp_jonCommented:
No problem :)

Pleasure to help out.
0
All Courses

From novice to tech pro — start learning today.