Solved

Printer Spooler problem in a Windows XP Pro workstation

Posted on 2010-09-16
11
542 Views
Last Modified: 2012-06-27
I have one Windows XP Pro workstation were the Printer Spooler stops constantly and it does not restart automatically.

I already have set the recovery to restart the service under subsequent failures (all three options are set to restart)

When the service stops I can manually restart without any problems. It tends to stop every few days or so

Any ideas?
0
Comment
Question by:Gerhardpet
  • 3
  • 3
  • 2
  • +3
11 Comments
 
LVL 17

Expert Comment

by:Nik
ID: 33691797
Delete all printers installed in the system
Open Print Manager | Server Properties | Drivers tab
Remove all of the drivers listed
Restart and see if this problems is still happening.

0
 
LVL 11

Expert Comment

by:kaskhedikar_tushar
ID: 33691803
Hello,

Restore your system.

start - programs - accessories - system tools - system restore

& select the date.

Regards,
Tushar Kaskhedikar
0
 
LVL 1

Expert Comment

by:takwirirar
ID: 33691812
I think this points to an issue with the drivers of whatever printers you have. Usually the Print Spooler works. I'd suggest
1. Open Printers and Faxes
2. Right click in the white space
3. Click Server Properties
4. Go to Drivers
5. Delete all of them
6. Go to C:\windows\system32\spool\drivers and delete everything in there
7. Reboot the PC
8. Reinstall the printer(s) and make sure the Print Spooler service is running
9. Monitor the situation
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 
LVL 77

Expert Comment

by:arnold
ID: 33691814
Check the system/application event log for the cause of the spool service stopping.
0
 
LVL 1

Author Comment

by:Gerhardpet
ID: 33691823
nimatejic,
Already tried your suggesting but still the same problem.

Tushar,
I'm not sure how restoring the system would help because this is an on going problem.
0
 
LVL 1

Author Comment

by:Gerhardpet
ID: 33691857
takwirirar,
The only thing I have not tried is to delete everything in Go to C:\windows\system32\spool\drivers and delete everything in there after I uninstalled the drivers

I will give that a try
0
 
LVL 17

Expert Comment

by:Nik
ID: 33691858
0
 
LVL 17

Expert Comment

by:Nik
ID: 33691870
You can also just backup your profile and try with a new one.
0
 
LVL 3

Accepted Solution

by:
Willy Van den Houten earned 500 total points
ID: 33691931
make a bat file : net start spooler.

Instead of restarting the service try

Run a program and point to the bat file.
0
 
LVL 1

Expert Comment

by:takwirirar
ID: 33691975
I also figured sometimes freakishly its to do with what is being printed, I remember this problem used to happen when only a certain document was printed, as soon as you tried to print another the Print Spooler would fail. Check the users behaviour to eliminate such things
0
 
LVL 1

Author Closing Comment

by:Gerhardpet
ID: 33694737
This will work well for me and I don't have to monkey around with the drivers
0

Featured Post

Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
changing harddisk on computer in corporate 10 69
Problem to App source 6 71
AD architecture diagram 5 34
Sony EVI-D70 and Skype 2 34
Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question