Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

SQL 2008 sqlserv.exe using using loads of ram

Posted on 2010-09-16
6
457 Views
Last Modified: 2012-05-10
Hi,
sqlservr.exe on Windows 2008 sbs 64bit running SQL 2008 is constantly maxing out the ram in the server.
There is 16gb installed and sqlservr.exe is using 7.5gb basically all of the free space.

If you restart the service it shrinks then grows again after a day or two.

Please help,

Regards,

Andy

0
Comment
Question by:actsystems-uk
6 Comments
 
LVL 3

Expert Comment

by:drpoppers
ID: 33692276
It alsways does that, SQL will grab every bit of ram it can to hold as much of the DB as possible, unless it's causing problems it should be fine.
0
 

Author Comment

by:actsystems-uk
ID: 33692296
It has slowed the server down to a crawl before - is there no way of defining a max amount of ram to be used?
0
 
LVL 57

Accepted Solution

by:
Raja Jegan R earned 250 total points
ID: 33692332
Kindly configure Min and Max Server Memory in SQL Server to allocate RAM for SQL Server.
And do let us know if there is any values already configured over there..
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 

Author Comment

by:actsystems-uk
ID: 33692413
Hi rrjegan17,
I have been into Microsoft SQL Server management studio
right clicked the sql server > properties > Memory
set the maximum server memory (in mb) to 7000

the task manager shows sqlservr.exe at 7.5Gb

Is there another way of setting the min and max?

Regards,

Andy

0
 
LVL 39

Assisted Solution

by:BrandonGalderisi
BrandonGalderisi earned 250 total points
ID: 33692467
SQL Server will still consume memory for each connection to the server and other things slightly above what you set.  This is normal behavior.
0
 

Author Comment

by:actsystems-uk
ID: 33692585
thanks bit of a red herring that one - changed the value to 5gb and now it says 5.5gb in the processes so all sorted.

Thanks for all your help.

Regards,

Andy
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

The Need In an Active Directory enviroment, the PDC emulator provide time synchronization for the domain. This is important since Active Directory uses Kerberos for authentication.  By default, if the time difference between systems is off by more …
Occasionally there is a need to clean table columns, especially if you have inherited legacy data. There are obviously many ways to accomplish that, including elaborate UPDATE queries with anywhere from one to numerous REPLACE functions (even within…
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…

809 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question