Solved

Connecting cable between cisco catalyst 2960 switch and Cisco 2811 router

Posted on 2010-09-16
9
2,090 Views
Last Modified: 2012-05-10
Hi there,
I just replaced the cable to cat 6 connecting my cisco 2811 router and Cisco 2960 switch and when I check the port status in IE for the switch port status it shows 'port has faulty link, speed 100mbps, Duplex half'.
Am I using a wrong cable?
0
Comment
Question by:amanzoor
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
9 Comments
 
LVL 3

Expert Comment

by:kf4zmt
ID: 33694285
What kind of cable is it?

Are the ports configured to a certain speed & duplex or are they auto-negotiating?
0
 
LVL 7

Expert Comment

by:GridLock137
ID: 33695421
make sure it's a straight-through cable, check the status on the interfaces on both sides. if you see it as up/up your are good, anything with a down status of course is not, check your port and interface settings, like duplex and speed, check the cable again and hot it sits in the interface your are connecting it to, make sure it clips in.

try shutting down the interface and bringing it back up by running shut command then no shut command. cat6 shouldnot matter but if you can find a cat5e try that just to eliminate that from the picture.  
0
 
LVL 4

Author Comment

by:amanzoor
ID: 33695799
Kf4:
Its a straight through patch cable cat6, On my cisco catalyst switch the port is set to Speed=Auto and Duplex=Auto.  Do I have to change something here?
Grid:
Its straight through.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 3

Accepted Solution

by:
kf4zmt earned 500 total points
ID: 33695828
Try setting the speed and duplex on both devices to:

speed 100
duplex full

Sometimes auto-negotiation doesn't work well.
0
 
LVL 4

Author Comment

by:amanzoor
ID: 33696043
kf4:
Excellent my friend you did it.  
The port is healthy again.  I really appreciate your time.
Thanks
0
 
LVL 4

Author Comment

by:amanzoor
ID: 33696079
Whats going on.  I did not request to close it.  I just accepted the answer.
0
 
LVL 3

Expert Comment

by:kf4zmt
ID: 33696131
I don't think amanzoor meant to schedule a close.
0
 
LVL 3

Expert Comment

by:kf4zmt
ID: 33696143
Glad that fixed it.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses
Course of the Month5 days, 19 hours left to enroll

626 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question