redirect domain to blog keep mail at domain

I want to redirect domain to blog at 65.39.205.54 (SquareSpace); currently works ok for www.emisstrade.com but not for emisstrade.com (w/out www). There is no mail server at SquareSpace; I get mail at 74.220.207.142. So, if I delete the A record for emisstrade.com, the redirect to the blog will work, but the mail will not.

How do I get mail at 74.220.207.142? change CNAME records to 74.220.207.142? replace CNAME with A and set records to 74.220.207.142? other?

see attached image;
DNS-settings-09-16-10.png
nemo7311Asked:
Who is Participating?
 
wdurrettCommented:
dd is right.  You should set it up as follows:

MX = mail.emisstrade.com

A records:
www = 65.39.205.54
(same as parent) = 65.39.205.54
mail = 74.220.207.142

0
 
ddiazpCommented:
for Email you need to also add an 'MX' record for the domain.

Add an MX record with domain.com (domain you want to receive email from) and point it to the IP address you want to receive email on.
0
 
nemo7311Author Commented:
problem resolved
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.