Cannot change password thrue logon over PNAgent by Wyse Xenith thinclient

We have XenDesktop4 + XenApp6 environment. We have one WI + SG server and there is a PN Agent site. Users are connecting to Windows Desktop by Wyse Xenith thinclient. It works well but if password is expiring or if admin set that user needs to change password on next login it doesnt work. Basically if admin has asked user to change password and user is loging in by Wyse Xenith his login will fail because there is no any possibility to change password. I have tried to change password against same PN site from Windows by online plugin and it's working as expected. I have heard that I should maybe configure this somehow by wyse ini file but I havent found any information how to do it. Does anyone has experience about this issue?`
thaapavuoriAsked:
Who is Participating?
 
LazyeyesConnect With a Mentor Commented:
It works now on C10 terminals with 7.0.0_34 firmware.
0
 
dnsguru44Commented:
Do you have the self service feature configured correctly for single sign on?
0
 
thaapavuoriAuthor Commented:
Could you clarify a bit? I havent configured single sign on...
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
dnsguru44Commented:
well, I should state that the SSO feature is an add on if you don't have platinum edition.  Also, SSO plug-in is also needed and I'm not sure how that would work with WYSE.

ssvc.jpeg.bmp
0
 
thaapavuoriAuthor Commented:
I have a platinium edition. SSO is not configured. But users are able to change their password thrue web interface and thrue PN Agent. Only problem is Wyse Xeniths. So are you sure that SSO would solve this issue?
0
 
dnsguru44Commented:
I'll be the first to admit that I am not sure if this will resolve your issue... :0

What version of ICA client is installed on the WYSE terminals?
0
 
thaapavuoriAuthor Commented:
We are using Wyse Xenith. That ICA client is built in on these thinclients and I think that it'w Wyse's own version. There is no possiblity to update it.
0
 
dnsguru44Commented:
Add the following parameter to your WNOS.INI:
                                           
 
PasswordServer=icaserver
Where "icaserver" is and IP address or DNS name of a server you can log-in to change the password.

It's worth a shot.
0
 
thaapavuoriAuthor Commented:
This sounds clever. This icaserver. Is it our Domain Controller or Webinterface server or which server it should be. If I should type there our domain controller's name this will probably work in our internal network but we have also users out side of our network and there this might be a problem. However, this would be a huge step forward.
0
 
dnsguru44Commented:
it would be the WI server...  Let me know if that works.
0
 
thaapavuoriAuthor Commented:
I tried that but it didnt work...
0
 
LazyeyesCommented:
We have now the same problem.
After upgrading Citrix Web Interface 4.6 (Windows 2003 Server 32 bit SP2) to Citrix Web Interface 5.3 (Windows 2008 Server R2), users are not presented with the change password dialog on the Wyse C10 terminals when their password expires.

0
 
thaapavuoriAuthor Commented:
I have heard that version 5.2 would work but I havent had time to test it. Here is also my post about this: http://forums.citrix.com/thread.jspa?threadID=273885 today I get newest post but I havent tested it yet. However, I think that this WI version might be main thing.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.