Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Cacti Installation - Incorrectly chose Apache, no web page displaying

Posted on 2010-09-16
4
Medium Priority
?
1,333 Views
Last Modified: 2012-05-10
I am very new to Linux, so this may be an obvious solution ... just not to me:)

I am running Ubuntu 10.04 LTS with Nagios 3.2.2 installed and working properly.
I attempted to install Cacti 0.8.7, but, made an incorrect choice (I believe) on the web server option.

I selected Apache rather than the correct Apache2, which is installed on our computer.

I attempted install with the instructions from this site:
http://www.ubuntugeek.com/install-and-configure-cacti-monitoring-tool-in-ubuntu-9-10-karmic-server.html

And I attempted uninstall with these instructions:
apt-get remove --purge cacti
apt-get autoremove --purge
apt-get clean

Followed by a reboot (Windows habit!) and an attempted reinstall.
The reinstall did not present the 'Configuring libphp-adodb option' questions etc.

On the uninstall I did read this message:
" /etc/init.d/apache not found"

I have navigated my way around the file system folders some, but, honestly feel like I'm bumping into things in the dark.  Anyone able to shed some simple instructions light for me?

Thanks!

0
Comment
Question by:pridenetadmin
  • 2
  • 2
4 Comments
 
LVL 1

Accepted Solution

by:
Stefan Schnyder earned 2000 total points
ID: 33752501
Hey pridenetadmin

I've got a very easy way for you to install cacti. Since a lot of distributions also have cacti in their repositories you should take advantage of that. For your cacti to work properly you need the 'cacti' package itself and its dependencies (for example apache2).

The cacti version in the Ubuntu 10.04 repos is 0.8.7e. The newest version though is 0.8.7g. So you should install the cacti package from source.
Another package which you should install from source is rrd. The best version to work with cacti is 1.2.27.

To get all needed dependencies do the followning:
* Open a terminal window and login as root (sudo so -)
* apt-get update && apt-get install cacti (do NOT selcet 'yes' and start the installation)
* What you see now is the complete list of all packages needed for the cacti installation. Copy the list of packages to a text editor, delte the 'cacti' and the 'rrdtool' entry and make the whole list one line.
* Use the package list now to install all dependencies: apt get install 'copy & paste the line here'

With that, you've got all dependencies needed for cacti to work. Now:
* Download rrd 1.1.27 from http://oss.oetiker.ch/rrdtool/pub/?M=D and install it, following the instructions
* Download cacti from http://www.cacti.net/download_cacti.php (the tar.gz archive) and install it, following the instructions
* Create an apache2 virtual host to point the webserver to your cacti folder (see attached code - edit paths for you installation)
* Open a browser on that machine and and got to http://127.0.0.1

Try that and tell me your results. Good luck.

Air

<VirtualHost *:80>
        ServerAlias cacti
        DocumentRoot /var/www/cacti/
        <Directory />
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ErrorLog /var/log/apache2/cacti-error.log
        LogLevel warn
        CustomLog /var/log/apache2/cacti-access.log combined

</VirtualHost>

Open in new window

0
 

Author Comment

by:pridenetadmin
ID: 33772081
I was able to uninstall and then reinstall upon trying once again.  I didn't specifically use all of these steps, but, this is a very thorough instruction set with links, so that works for me.  Thanks for the input.
0
 

Author Closing Comment

by:pridenetadmin
ID: 33772094
Solution provided is complete.
0
 
LVL 1

Expert Comment

by:Stefan Schnyder
ID: 33786097
I'm glad you could achieve your goal. Have fun :)
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Despite its rising prevalence in the business world, "the cloud" is still misunderstood. Some companies still believe common misconceptions about lack of security in cloud solutions and many misuses of cloud storage options still occur every day. …
Suggested Courses

783 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question