Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Terminal Server app crashing for one user

Posted on 2010-09-16
7
Medium Priority
?
1,474 Views
Last Modified: 2012-05-10
We are running Terminal Server on Windows 2008.  I have one user who logs into TS and immediately after logging in, gets a message "Acrobat Distiller has stopped working".  This is also logged in the Event Logs as an application crash.  This error is happening only for this one user who really needs to use Adobe Acrobat.

The fact that this is occurring to just one user would indicate a profile corruption issue.  I've never deleted profiles from a Terminal Server so I am a little cautious.  Profiles are configured as roaming profiles.  Can I just delete her roaming profile?  Do I also need to delete the local profile folder on the server.  This is one of our key employees so I don't want to render her inoperable.

What would be best the procedure for trying to resolve this Adobe crash?
0
Comment
Question by:rutaliet
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 4

Expert Comment

by:cmrayer
ID: 33696867
Once the user has logged off their local copy of the roaming profile should also go.  If there are messages about files being locked then this usually indicates either a busy server or a corrupt profile.

You can safely delete the profile from the terminal server after log off and it is good practise to reboot a terminal server at least once a month (we do it weekly) and delete all profiles (or parts of profiles) left behind.

If this does not fix the issue, copy her profile from the profile server to another area (making sure you unhide operating system files first) and then delete it.  The system will create a new profile but IE favourites and application customisations will be lost.  They can however be recovered from the saved copy.
0
 

Author Comment

by:rutaliet
ID: 33701993
Thanks for the quick response !  I still don't really understand how to deal with the corrupt profile for the one TS user.  I tried something this morning that just confused me more.  Here is my environment:

I have two Terminal Servers:
TS1 is my production server
TS2 is a standby backup server (that I also use for testing)
TS profiles are configured for users to put their profile on a file share on a different server.  By reviewing the profiles on the file share and looking at the time stamps, I can see that these are updating daily.

On the actual terminal servers, there is a folder for each user in the Users folder.  I am assuming that these are the locally cached copies of the profile and that they can be safely deleted.  We do not have the setting configured (for now)  that deletes the local copy on logout.  We recently had an issue on TS1, so we failed over to TS2 until the issue was resolved.   Therefore, TS2 also has a profile folder for each user in the Users folder.

As a test, this morning,  I logged on to TS2 and manually deleted the local copy of the profile folder in the Users directory for the user that is having the Adobe problem.  I was under the assumption that when this user logged in to TS2 that the roaming profile would be accessed and a new local folder would be created.  This was not the case.  After I deleted the local folder and logged on as the user, the errors about "there is no profile and a temp profile will be used but won't be saved"  came up.  The Adobe errors was not generated, but clearly, something was not right about what I did.  I restored the deleted folder.

This did seem to confirm that the Adobe error is indeed a profile issue.

So I am still reluctant to go and mess with this person's profile.  I am really confused about why the roaming profile was not used after the local copy was deleted.  I tried researching best practices for managing user profiles on TS but really have not found anything useful.  I anticipate having corrupt TS profiles at some time in the future, so I need to know the CORRECT way of successfully deleting a TS profile without screwing up the user.  And why can't I delete the local folders?  
0
 
LVL 4

Expert Comment

by:cmrayer
ID: 33738025
The error you get when logging on after deleting the cached profile on TS2 suggests that TS2 is not getting the profile from the file server.  Do you get this error if you delete other users.  

Also rather than deleting the folder it is better to go to the properties of my computer, click advanced and delete the profile from there.

Try on a test user before working on this important one!

Is TS1 back, if so try on that also.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:rutaliet
ID: 33757432
I did resolve my application error issue by deleting the user's TS profile.  I was concerned about following the correct sequence of steps - it's probably obvious to most experts, but since I never needed to do it before,  I wasn't sure exactly of the steps. So for others that might need this info, here is the process that worked for me:

Make sure user is not logged into any TS.
To be safe, make copy of the profile folder on the network share (may need to take ownership first)
Delete profile on TS1 using System Properties - Advanced - User Profiles (local profile folder is now gone).
Delete profile on TS2 using System Properties - Advanced - User Profiles (local profile folder is now gone).
Remove TS profile path from user's AD profile and Save (probably not needed but I did it to be safe).
Delete profile folder on network share.
Add TS profile path back to user's AD profile.
Logon as user to TS1. Verify no errors.
Logon as user to TS2. Verify no errors.
Log user off from both TS Servers.
Restore any needed items from the copied profile into the new profile on the network share.
Log back on as user to test items.
0
 
LVL 4

Accepted Solution

by:
cmrayer earned 1500 total points
ID: 33758517
I think that I gave rutaliet the answer seeing as he fixed the problem by following my suggestion of deleting the profiles through mycomputer properties.  He correctly states that the profile path changes were not required.

I am not sure why he does not want me to be awarded the points?

Cheers,

Charles
0
 

Author Closing Comment

by:rutaliet
ID: 33758775
The suggestions was correct but not complete.  There was no mentiong that the roaming profile needed to be deleted at each TS and that the roaming folder needed to be manually deleted from the file share.  The comments did lead me to the correct solution, but additional steps were required for full resolution.  I am happy to award points for assistance, but I received the remainder of the advice from a different resource.
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
After seeing many questions for JRNL_WRAP_ERROR for replication failure, I thought it would be useful to write this article.
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question