Solved

CRM 4.0 Internet Access issue

Posted on 2010-09-16
19
491 Views
Last Modified: 2012-05-10
I have a small deployment of CRM 4.0, one SBS server 2003 with Exchange running,
one 2008 Enterprise server running SQL 2008, CRM 4.0 & SharePoint. Inside the network, all the workstations
access CRM fine, Outlook connectors work fine. But I cannot seem to get access from the
internet. I also have two private DNS servers to direct my personal traffic.
I ran the IFD tool, DNS resolves fine. I am getting past my hardware firewall, to the point
of the CRM server asking for login credentials, once logged in, I get a page not found error.
I did a port scan, the port is open, hence the login request. I am certain I am reaching the CRM
server, however, once logged in, the browser is not being directed properly. And yes, I have
rebooted several times. SharePoint works just fine from the internet and logins work just fine.
 Any suggestions?
 
0
Comment
Question by:michaelm352
  • 11
  • 7
19 Comments
 
LVL 8

Expert Comment

by:Aftab_Khateeb
ID: 33698495
Have you run a trace and check logs? CRMDiag4Tool wuld be helpful...
0
 

Author Comment

by:michaelm352
ID: 33701546
I ran the trace and logs, I am just learning Dynamics, but dont see anything there that provides a clue.

As I am reaching the login on the server, I suspect it is some sort of routing issue to the page.

Everything works fine on the Intranet.

I am hesitent to attach the trace/log files. anything in particular i can relay?

I appreciate any help!
0
 

Expert Comment

by:Auto1014
ID: 33706000
When deploying the IFD are you useing HTTP or HTTPS for the IFD Domain Scheme, and if you are using Https do you have your certificate in place?
0
 

Author Comment

by:michaelm352
ID: 33711592
for now i am using httt.
0
 

Author Comment

by:michaelm352
ID: 33711594
oops... http only
0
 
LVL 8

Expert Comment

by:Aftab_Khateeb
ID: 33712818
may i know what is the URL that you are trying to access.

Is it something with some name like http://myserver/<organization name>?
If thats the case check if you try with IP Address and see if it gets resolved. Also if you are using a name to resolve, find the host file (.htc) in the server and add an entry for this IP Address and the name.

Let me know how u go
0
 

Author Comment

by:michaelm352
ID: 33712992
Presently i am using the static public IP address followed by the port number. I have the firewall setup to route the port to the server and that appears to be working fine, as I do  a port scan  and the port is open.

Again, i am getting past the firewall and to the server, being asked for credentials, but once i am logged in, the page cannot be found. It is as if the server does not know where to route the outside request once it has be authenticated.

And, THANKS for any help, i am mystified!
0
 

Author Comment

by:michaelm352
ID: 33713002
For further information, the url is http://64.45.234.71:8080 which will bring up a log in box, log in is successfull but returns the following:

The webpage cannot be found
 HTTP 404  
   Most likely causes:
•There might be a typing error in the address.
•If you clicked on a link, it may be out of date.
 
   What you can try:
     Retype the address.  
 
     Go back to the previous page.
 
     Go to  and look for the information you want.  
 
     More information

This error (HTTP 404 Not Found) means that Internet Explorer was able to connect to the website, but the page you wanted was not found. It's possible that the webpage is temporarily unavailable. Alternatively, the website might have changed or removed the webpage.

For more information about HTTP errors, see Help.
 
0
 
LVL 8

Expert Comment

by:Aftab_Khateeb
ID: 33713263
Ok, have you checked below step
in IIS expand Web Service Extensions, right-click ASP.NET v2.0.50727, and then click Allow
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 

Author Comment

by:michaelm352
ID: 33713409
I do not see that as an option? Screen shot attached of my options.
ss.png
0
 
LVL 8

Expert Comment

by:Aftab_Khateeb
ID: 33722174
Hi Michael,
As I have not used SBS server before, I am not sure where exactly is the setting. unfortunately i dont have any SBS virtual image. I guess you may need to check the help and it wuld be easy enough for u to query for webservice extension.
0
 

Author Comment

by:michaelm352
ID: 33725478
I am using Server 2008 Enterprise, not SBS.
0
 
LVL 8

Expert Comment

by:Aftab_Khateeb
ID: 33732074
sorry about that i didnt happen to notice it. I guess if u are in Enterprise server it should have been already enabled.  have you tried creating another  test organization in the same server (take backup before if its in production) is it having the same issues? if you have any other environments with mirror image, u culd try creating a new organization and check if u are able to access it and then import the customizations from production and try again.
0
 

Author Comment

by:michaelm352
ID: 33738141
Presently the server is in lab still, i have not deployed to production yet, so anything goes! Create a new organization winin Dynamics? i will give that a try when i return to the lab.
0
 
LVL 8

Expert Comment

by:Aftab_Khateeb
ID: 33740363
You can use Deployment manager in CRM server to create a new organization, I hope your CRM Dynamics is of enterprise edition (which allows to create multiple organizations in same server).  Creating new organization is not a big deal as its sort of wizard steps and you could find it in implementation guide
0
 

Author Comment

by:michaelm352
ID: 33853367
As this was a learning experience in a lab situation, i have began reloading the servers from scratch and will attempt another install on a clean machine and keep all informed of the progress.
0
 
LVL 8

Expert Comment

by:Aftab_Khateeb
ID: 33944711
Sure. do let us know about the progress. let me know if you come across any issues
0
 

Accepted Solution

by:
michaelm352 earned 0 total points
ID: 34928179
I ended up reloading the SBS server from scratch, then loaded a second server dedicated to Dynamics and SQL.. all works great now.
0
 

Author Closing Comment

by:michaelm352
ID: 35178805
Non of the solutions offered corrected the issue. Ended up reloading the server from scratch.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Dynamics CRM Contacts Sync 5 41
CRM 2016 onl cloud - Web Development 2 118
CRM 2011 Missing Fields in Dataset 13 84
CRM 2011 Fiscal Calendar Options 2 78
On Sep 22nd 2014 Microsoft released Update Rollup 1 for Microsoft Dynamics CRM 2013 Service Pack 1 and back in July Update Rollup 3 was released.  So we now have:   Update Rollup 1Update Rollup 2Update Rollup 3Service Pack 1Update Rollup 1 for S…
For cloud, the “train has left the station” and in the Microsoft ERP & CRM world, that means the next generation of enterprise software from Microsoft is here: Dynamics 365 is Microsoft’s new integrated business solution that unifies CRM and ERP fun…
A company’s greatest vulnerability is their email. CEO fraud, ransomware and spear phishing attacks are the no1 threat to a company’s security. Cybercrime is responsible for the largest loss of money to companies today with losses projected to r…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now