Problem importing Exchange 2010 SSL Cert

I bought a SAN/UCC Cert.  I am having trouble importing on my Exchange 2010 box.  I generated the CSR from my Office Communications Server.  I was able to successfully install the cert on that server.  I am now trying to install it in Exchange.  

I went through EMC, Server Config, selected server, and imported the certificate there.  The problem is that it doesnt show up in EMC where I would then be able to assign it to the services.  

I ran this command Get-ExchangeCertificate in EMS and it doesnt show up there.  The cert is showing up in MMC/Personal Store Certificates though.

I also attempted to re-import through EMC and it says it already exists.

Any help would be very much appreciated.  Thanks.
Who is Participating?
AkhaterConnect With a Mentor Commented:
what you did wrong is that you are trying to import the file you have downloaded

what you should do is the following

   1. on the OCS server
          * Start run mmc
          * File add/remove snap-ins
          * certificates -> computer certiciates -> local computer
          * Open the personal certificate store and export the certificate you have just imported
          * when prompted say you want to include the Private Keys and make sure NOT to select to delete them after export
          * while doing so you will be asked to input a password put one
          * copy the PFX file to the exchange server
   2. On the exchange server
          * Delete the certificate you had previously imported
          * import the one you have just exported
          * be happy

Please assign the certificate in IIS 7. you have a option there as Server Certificates, where you can remove and assign the certificates.

Please check out. Hope this helps!

On the MMC, do  you see the pvt. key on those certs?

If No, want to try the following commands:
1. certutil -addstore my cert.cer
2. certutil -repairstore my "<Thumb Print>"(of the new cert) and you should get the PVT key
obautistaAuthor Commented:
Thanks so much.  The instructions AKHATER gave worked like a charm.  Thanks again...
obautistaAuthor Commented:
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.