Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

PC Not Receiving IP Address From DHCP Server

Posted on 2010-09-16
10
Medium Priority
?
579 Views
Last Modified: 2012-05-10
Hi;

I have a machine which does keeps receiving a 169. . . address on its home network. The home network is a Windows 2008 AD domain. The machine was cleaned and separated for specific use by employees for internet access.

The onboard card sometims works at my office so a different PCI ethernet card was installed which works perfectly at my office. However, when it was returned to the home network the new card stopped receiving an IP address.

Eset Smart Security was previously installed but it was removed as part of the troubleshooting process. I have attached my mobile machine to the network cable used by that machine and I immediately got an IP address and was able to browse the internal network and internet.

I need to get it resolved tomorrow so your assistant would be appreciated.
0
Comment
Question by:mavcom
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 20

Expert Comment

by:wolfcamel
ID: 33698640
try dropping the speed on the network card, or trying a different port.
0
 
LVL 11

Accepted Solution

by:
kaskhedikar_tushar earned 2000 total points
ID: 33698641
Hello,

Check the physical connectivity such as patch cord, Crimping, from switch ports.
Then check bios setting on your computer.
Run this command IPconfig/ renew
From server side please check the DHCP scopes.

Regards,
Tushar Kaskhedikar  
0
 

Expert Comment

by:gaurav_670
ID: 33698695
i think the ip address or the machine name is clashing on the network check the computer name and try

regards
gaurav
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 8

Expert Comment

by:RGRodgers
ID: 33698751
Test the machine on a different cable.  My thought is that it will fail there, too.
Delete the protocol stack and driver for the card.  Then, install updated drivers and allow the stack to be rebuilt.  
0
 
LVL 3

Expert Comment

by:Chocco
ID: 33698756
Also have a look at the duplex / speed settings on your network card..

Not sure of your switching infrastructure, but there may be mismatches of duplex/speed - ie port hardcoded to 1GB. Network card only being 100mb etc..

Also, as it is a PCI card, that works on a different PC - ie different software, i would jump on the manufactures website, and download the latest drivers.. The drivers on the machine may not have been installed properly / become corrupt, or may need an updated version to work with the System OS SP, patches etc...

Cheers
0
 

Author Comment

by:mavcom
ID: 33699942
Ok;

The cable is working . As I indicated my netbook has no issues when using the same connection.

Secondly why would I need to rebuild the stack for a new card.

I have already renamed the computer and ran ipconfig/renew, I have also tried giving a static ip address .

Finally the new card works on the same machine just at a different physical location on a different network.

All of the things mentioned above have basically already been tried.
0
 
LVL 2

Expert Comment

by:brammer90
ID: 33700080
a couple of things:
What is the make / model of the card and  switch that its plugged into.
1st thing i would try is to set a static ip address to an address that is the same network address as te rest and set the last octect to an address that is not on the list of host address and not used by any other machine with your server as the default gateway and the same mask as the server(obviously) then try to ping the server if that fails then DHCP is not your problem - only a sympton of a bigger problem.
remember your laptop my be 100 mb using 4 cores of the cable and 1gb uses all 8 and i've also seen problems where the machine sees the connection but no data transferred if one of the cores are faulty. - i would use a cable tester to check the link from the back of the PC right to the switch.  
if youy can ping then i wonder...
Have you checked the event log on the client machine for any errors eg dhcp client service not started.
have you checked the dhcp server admin tool on the server to see if the machine name is listed - if so delete the machine name from the list and try again
let me know how you get on
0
 
LVL 51

Expert Comment

by:Netman66
ID: 33701047
Make sure both the DHCP and DNS Client services are started and set to Automatic.  You can look for these in Services.msc.

0
 
LVL 26

Expert Comment

by:Leon Fester
ID: 33701150
Have you tried creating a DHCP reservation for this PC?
This will confirm that the PC is at least reaching the DHCP Server.

Make sure that there are no other settings enabled on the TCP/IP configuration, except, Obtain an IP address automatically.

If you really want to start troubleshooting then install a network sniffer tool to see if network card broadcasting the correct information.

Do you know if there is a Network Access Control device on the network?
This could be stopping this PC from obtaining an IP address?
0
 

Author Closing Comment

by:mavcom
ID: 33889016
Hi;

The tech from my office who did the cable did not follow the standard code but just put the pairs sequentially. While it worked on my mobile machine it would not work on the pc. While on another job with another tech from the company I insisted that he use the right sequence and at that point he indicated that the other tech had not used it there. I changed the ends using the right sequence and that was it. Everything worked fine.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Most of the applications these days are on Cloud. Cloud is ubiquitous with many service providers in the market. Since it has many benefits such as cost reduction, software updates, remote access, disaster recovery and much more.
This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question