Solved

Exchange 2010 SP1 - GAL's empty

Posted on 2010-09-17
6
1,923 Views
Last Modified: 2012-05-10
Hi,

last night I upgraded our Exchange 2010 server to SP1. Since then the Exchange 2010 mailboxes get empty GAL's. We have a coexistence in our Exchange farm, there are a few Exchange 2003 servers.
So the legacy users (mailboxes on the Exchange 2003 server) get the correct GAL.

This error I found in the Event Viewer:
Process Microsoft.Exchange.AddressBook.Service.exe (PID=2788). Coudn't find a global address list for user '(null)' (SID='S-1-5-21-353336168-582209970-19082705-2111')

Please help us out, as the users can't access the GAL, but more importantly their BlackBerry's aren't working...
0
Comment
Question by:ISBNET
  • 4
  • 2
6 Comments
 
LVL 11

Expert Comment

by:Coast-IT
ID: 33699345
I can't take credit for this, here is the same problem with another user ;

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_26320925.html
0
 

Author Comment

by:ISBNET
ID: 33699501
The URL you gave me is about Offline Address Books... This has nothing to do with GAL's.
But thanks for your time anyway :)
0
 
LVL 11

Expert Comment

by:Coast-IT
ID: 33699976
Apologies.

I noticed that the exact same text that you are loking for exists in that message ;

EventID: 2913
Process Microsoft.Exchange.AddressBook.Service.exe (PID=9816). Coudn't find a global address list for user '(null)' (SID='S-1-5-21-1669006098-685327170-2493165136-5589')
0
Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 

Author Comment

by:ISBNET
ID: 33788812
Anyone ?
0
 

Accepted Solution

by:
ISBNET earned 0 total points
ID: 34238149
Since Exchange 2010 SP1 there is no need anymore for the MsExchQueryBaseDN attribute.
If anything is filled in but <clear> the user will not see the GAL.

After clearing this for all our users, all problems were solved.
0
 

Author Closing Comment

by:ISBNET
ID: 34276679
Found the answer through Google.
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
This article shows how to deploy dynamic backgrounds to computers depending on the aspect ratio of display
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now