• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 638
  • Last Modified:

TCP/IP Filtering + DNS Resolving Issue

HI,

I have enabled TCP/IP Filtering on my Windows server 2003 to block the inbound traffic, I have enabled following ports in TCP/IP Filtering and Enabled TCP/IP Filtering
TCP ports: 20, 21, 25, 53, 80, 110, 143, 443, 807, 808, 1433, 3389, 5357, 8004, 8010 and 8011
UDP ports: 6514, 6515 and 6516
These ports I require.

One Strange Thing is happening that Now I am not able to resolve any DNS Name like google.com.
If I disable the TCP/IP Filtering then I can easily resolve the domain name google.com


Any one can help me in this matter. Server is on Remote location so I can't use any firewall software. I require to enable only TCP/IP Filtering.
0
tanujchandna
Asked:
tanujchandna
1 Solution
 
Mike ThomasConsultantCommented:
You should have UDP 53 Open also iirc.
0
 
tanujchandnaAuthor Commented:
Hi

Forget to mentioned UDP port 53 is also enabled in Filtering.
0
 
leonepeterCommented:
doesn't dns also use UDP port 53? try that
0
Get Cisco Certified in IT Security

There’s a high demand for IT security experts and network administrators who can safeguard the data that individuals, corporations, and governments rely on every day. Pursue your B.S. in Network Operations and Security and gain the credentials you need for this high-growth field.

 
Otto_NCommented:
DNS look-up works on UDP 53 also.  And, since it is UDP, it needs to be permitted in both directions: In- and outbound (if you filter outbound traffic as well).
0
 
Otto_NCommented:
Sorry for my previous post: I only repeated what leonepeter said.  I think my mind is leaving me...

If you do allow both UDP and TCP port 53, please check if you still have a valid DNS server configured.  I assume you get your DNS through a static configuration?
0
 
Otto_NCommented:
If you do not get your IP addressing via static configuration, but uses DHCP, you will also need to permit UDP 67 & 68.  Although it should only affect the DNS configuration when the DHCP lease expires, and will also affect IP addressing of the server.
0
 
tanujchandnaAuthor Commented:
I am using Open DNS 208.67.222.222 and 208.67.220.220, Please understand when I disable TCP Filtering It works fine.
0
 
kaskhedikar_tusharCommented:
Hello,

Why are you using open DNS? Get a static IP address from your ISP & configure in router.
Install & configure DNS server on windows server 2003 & add DNS in forwarders.
 
http://support.microsoft.com/kb/814591
http://support.microsoft.com/kb/816792

Regards,
Tushar Kaskhedikar
0
 
Otto_NCommented:
OK, so it isn't via DHCP, and you do not need UDP 67 & 68.

I did a bit of research on the TCP/IP filtering functionality of Windows, and it seems that it block the packets based on its destination port number.  With a DNS query, the response would actually be directed not at TCP/UDP 53, but at an ephemeral port number, assigned from a dynamic range.  According to Microsoft's website, the range is from 1025 through 5000.

I would suggest that you permit this range as well, and see if it resolves your problem.  This would also allow any other return traffic for client processes on the server (i.e. if you want to open a web browser from the server).  Just take note that this could increase your security risk, but only if you have server processes litening in this range that should be blocked.
0
 
tanujchandnaAuthor Commented:
I didn't found any solution, I have used IPSec instead of TCP/IP Filtering.
Thanks to All
0
 
Otto_NCommented:
tanujchandna

If you do not like any of the proposed solutions, please request to have this question deleted, rather than leaving it open.  Or close it by accepting your own answer.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

NEW Internet Security Report Now Available!

WatchGuard’s Threat Lab is a group of dedicated threat researchers committed to helping you stay ahead of the bad guys by providing in-depth analysis of the top security threats to your network.  Check out this quarters report on the threats that shook the industry in Q4 2017.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now