Solved

Certificate warning message when using OWA

Posted on 2010-09-17
8
639 Views
Last Modified: 2012-08-13
Dear experts,

I am experiencing a rather strange behavior with certificate warning in OWA. And I think it is a problem with IE8.

We are using SBS2003 with self assigned certificate. I haven't export/import the self-assigned cert to user laptop so when users open OWA they all see the Certificate Warning message at the beginning. This is fine we have no problem with that, and we have no intention changing it.

However, upon setting up a new laptop an user report a rather strange behaviour, that when he uses OWA he sees this message at the beginning, which is fine. But then he sees this message EVERYTIME he opens an email, and that is not right and is very annoying.

It is still working the user only has to click continue..... but it is annoying. Is it some settings in IE that can be adjusted to aviod such? This problem only seems to happen to user with IE8 installed. IE7 or Firefox users are OK.

Thanks.
0
Comment
Question by:ormerodrutter
8 Comments
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33699802
Thats the default behavior for a self-signed certificate.

for that to go away, you can purchase a SSL with your OWA name - mail.domain.com
This affects all other browsers - IE8 / Mozilla / Chrome etc.

The issue is - the self-signed is issued in the name of SERVERNAME - and the domain is mai.domain.com
SERVERNAME doesnt match mail.domain.com

Please ask if you have more questions
0
 
LVL 23

Author Comment

by:ormerodrutter
ID: 33700020
I am a bit surprise MS haven't updated with a fix? Anyway I would rather prefer using Firefox, as it seems OK when doing my owa email through FF.
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33700062
There is no "fix" - this is by design.
That error message pops up to prevent fraudlent sites posing as www.bank.com etc

The default norm is to install exchange server with a ssl certificate. In case you didn't and you are using self signed cert then you will continue to get that.

User experience in ie8 is mich better than firefox

For example you can press shift + select multiple messages and then delete
In firefox etc you will have to check all boxes
0
 
LVL 5

Expert Comment

by:delmc
ID: 33700082
If you don't want to buy a SSL certificate, you can continue to use the self signed certificate and import it into the IE8 setup, this is done clicking install certificate and then selecting place all certificates to the following store, select show physical store and then select trusted root authorities, select local computer as the destination and then import. Finish the procedure, exit internet explorer and then retry OWA site to see if it has imported correctly. Sometimes takes a couple of attempts and needs UAC turned off in Windows 7 & Vista to complete successfully.
Although have to agree with sunnyc7 best way to go would be to use a third party SSL certificate from one of the providers such as godaddy, verisign, etc and importing it into the SBS setup.
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 
LVL 28

Accepted Solution

by:
sunnyc7 earned 300 total points
ID: 33700097
dont want to suggest importing as end-users start using that as default thing to do when SSL is "broke".
They may end up importing really bad cert for bankinc1.com with a exact UI
0
 
LVL 26

Expert Comment

by:e_aravind
ID: 33700371
Else...you can install the Microsoft Certification-Authority on the server/setup
Create-n-assign  the SAN cert for the exchange servers
By default the root cert. of the "Local Certificate Authority" will be installed on all the domain-joined machines
0
 
LVL 77

Assisted Solution

by:Rob Williams
Rob Williams earned 200 total points
ID: 33701342
I Too have to agree, at $30/year, even for one user a 3rd party certificate will save you a lot of time an energy, especially if you have any smartphones. I suspect you have spent that $30 in time already :-)

Regardless, I disagree. Usually you can accept the certificate warning (with SBS2003) once, and then not need to do so again. I just tested it with two sites using IE8, on Win7. In both cases I was asked initially, and then not asked again when opening e-mails, on one server, and on the second server the first e-mail opened asked (which I don't recall seeing before), but was not asked in ANY subsequent e-mails. I am curious as to why the difference. Have you tried adding the site as a trusted site.

As a minimum why not add the self signed certificate?
0
 
LVL 23

Author Closing Comment

by:ormerodrutter
ID: 33875118
Thx.
0

Featured Post

Too many email signature changes to deal with?

Are you constantly being asked to update your organization's email signatures? Do they take up too much of your time? Wouldn't you love to be able to manage all signatures from one central location, easily design them and deploy them quickly to users. Well, you can!

Join & Write a Comment

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
Find out how to use Active Directory data for email signature management in Microsoft Exchange and Office 365.
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now