Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Change SharePoint Site URL

Posted on 2010-09-17
3
Medium Priority
?
1,025 Views
Last Modified: 2012-06-22
I have a SharePoint 2010 server up and running called "hotbox".  I can access the server by going to http://hotbox/Sites/[whatever].  (Assuming of course that the computer you are using is on our company domain first).  The hotbox server uses Windows Server 2008.  What I need to do is assign a public URL to this SharePoint site so that anyone can access it (assuming they have the permissions).  For example, I want the url to be "http://team.mycompany.net".  How can I do this in SharePoint 2010?  Do I have to use Alternate Access Mappings in the SharePoint Central Administration?  I have TFS also running on this server, so i'm worried about breaking the connection between TFS and Sharepoint.  I should also mention that I want to get an SSL certificate for this url.  
0
Comment
Question by:ideamatics
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 11

Expert Comment

by:Coast-IT
ID: 33700933
Can't you leave the internal name as is and just add an A record for team.mycompany.net externally?

Once done, set up forwarding on your router for the necessary ports from outside.

to make things uniform, you can add an extra DNS namespace internally for mycompany.net and give the team. A record the internal IP of the sharepoint server.

This will not break any links you have because nothing changes, it just becomes accessible from outside.
0
 
LVL 11

Accepted Solution

by:
FastFngrz earned 2000 total points
ID: 33713740
It's all in the Alternate Access Mappings.  If you 'extend' the site with the AAM , it'll flow fine.  SSL certs mean another port on the firewall, and some tooling around in IIS, but this is generally easy.
0
 

Author Comment

by:ideamatics
ID: 33807048
Got it working. Open the SharePoint Central Administration Tool, click on Alternate Access Mappings. Make sure the "SharePoint 80" site is selected in the dropdown, and click Add Internal URL and enter "http://team.mycompany.net" for the URL, and select "Internet" as the zone.  Click Save.  Now if you want to use SSL, then repeat the same process but use "https://team.mycompany.net".  
0

Featured Post

Survive A High-Traffic Event with Percona

Your application or website rely on your database to deliver information about products and services to your customers. You can’t afford to have your database lose performance, lose availability or become unresponsive – even for just a few minutes.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
A while back, I ran into a situation where I was trying to use the calculated columns feature in SharePoint 2013 to do some simple math using values in two lists. Between certain data types not being accessible, and also with trying to make a one to…
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question