Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Unable to connect to Remote Desktop after successful connections

Posted on 2010-09-17
7
Medium Priority
?
939 Views
Last Modified: 2012-05-10
I have a PC (Windows XP) that is used for one of our road warriors.  For months, there hasn't been an issue with her connecting.  Over the last week or so, it seems that I have to reboot at least a couple times a week or she gets the generic "Can't connect to the remote computer" error.  If I reboot the machine, it works fine but then it seems that it doesn't terminate the session when she disconnects.

I've also verified that it's not only her that is unable to connect - if she has the problem, I can't connect remotely, either.

The last time, I was able to log in locally and verify that "Terminal Services" was still running.  I then logged off and she was able to connect normally.

I advised her to make sure that she was logging out of the machine, as opposed to simply closing the RDC connection (which, she admitted is what she had been doing previously), but that hasn't made a difference.

Any thoughts?
0
Comment
Question by:innotionent
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 2

Expert Comment

by:Hangulman
ID: 33701647
I was having a similiar problem with my system at home and it turned out that for some strange reason it was being assigned a different IP via DHCP than the IP reservation I set up for it in the router/DHCP server config.  Because of this subnet IP change, my port forwards couldn't reach the client computer from the internet.  Another thing to check is to make sure that the built in firewall and any firewall/AV software on her computer is not blocking port 3389, tsclient, mstsc and the RDP protocol.
0
 
LVL 4

Expert Comment

by:nuttytech
ID: 33701650
Set a timeout for the connection

1.Open Terminal Services Configuration.
2.In the console tree, click Connections.
3.In the details pane, right-click the connection for which you want to modify time-out settings, and then click Properties.
4.On the Sessions tab, above End a disconnected session, select the Override user settings check box. This allows you to configure time-out settings for the connection.
5.Configure the following time-out settings as appropriate:

In End a disconnected session, select the maximum amount of time that a disconnected session remains on the server. When the time limit is reached, the disconnected session ends. When a session ends, it is permanently deleted from the server. Select Never to allow disconnected sessions to remain on the server indefinitely.

In Active session limit, select the maximum amount of time that a user's session can remain active on the server. When the time limit is reached, either the user is disconnected from the session or the session ends. When a session ends, it is permanently deleted from the server. Select Never to allow the session to continue indefinitely.

In Idle session limit, select the maximum amount of time that an idle session (a session without client activity) remains on the server. When the time limit is reached, either the user is disconnected from the session or the session ends. When a session ends, it is permanently deleted from the server. Select Never to allow idle sessions to remain on the server indefinitely.

Notes
To open Terminal Services Configuration, click Start, click Control Panel, double-click Administrative Tools, and then double-click Terminal Services Configuration.

Group Policy overrides the configuration set with the Terminal Services Configuration tool.

These settings affect every client that uses the connection to connect to the terminal server. To define Session settings on a per-user basis, use the User Configuration Group Policies or the Terminal Services Extension to Local Users and Groups and Active Directory Users and Computers
0
 
LVL 5

Author Comment

by:innotionent
ID: 33702689
Thanks for the quick responses.

I don't see it being an IP or forewall issue because, again, it will work that first time as long as I reboot or (in at least two instances) log off the session physically at the PC.

I had actually thought of setting a timeout but couldn't find where to do it in XP.  I'm not seeing Terminal Services Configuration under Administrative Tools.
0
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

 
LVL 4

Accepted Solution

by:
nuttytech earned 2000 total points
ID: 33702861
1.Go to the Start Menu and click Run (or press the shortcut combination Windows+R).
2.In the prompt, type gpedit.msc and click OK.
3.In the left panel, navigate the hierarchical menu: Computer Configuration > Administrative Templates > Windows Components > Terminal Services > Sessions
4.Double click the “Sets a time limit for active but idle Terminal Services sessions” property to open up the properties window.
5.In the popup window, make sure the Enabled selection is chosen and the Idle Session Limit dropdown list is set to Never.
6.Click Ok and close all windows and applications
7.Reset the computer for the changes to take effect.

If you do not have that setting in gpedit.msc, delete (backup and delete) the adm folder out of c:\windows\system32\group policies\ then go back into gpedit.msc, it will recreate the adm folder and you should see the TS folder.
0
 
LVL 5

Author Comment

by:innotionent
ID: 33705815
Thanks, nuttytech, for the follow-up that got me the erminal Services configuration that I needed and now I have set a timeout.

I'm still having issues with connecting, though, so let's assume I was mistaken about it being an issue with the session staying open.  Any ideas on what else what would suddenly make an RDP connection that was working fine stop working?  If it stopped altogether, it would make sense.  It's the fact that I connect the first time and then I can't get back to it that is driving me nuts.
0
 
LVL 1

Expert Comment

by:ctown_larrymac
ID: 33747755
I've been having the same issue off and on.  Does the session "lock" if somebody else connects remotely that first time?  I don't see how it would matter, but then the whole issue is sort of strange.
0
 
LVL 5

Author Closing Comment

by:innotionent
ID: 33772209
The issue appears to have gone now, we haven't had any issues in over a week of fairly regular use.  Points to nuttytech because even though there was still an issue for the first day after setting the timeouts, that's the last thing that I managed to change before the issue cleared up.  Moreover, that was basically what I was hoping to implement anyway.
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is the first one of a series of articles I’ll be writing to address technical issues that are always referred to as network problems. The network boundaries have changed, therefore having an understanding of how each piece in the network  puzzl…
Trying to figure out group policy inheritance and which settings apply where can be a chore.  Here's a very simple summary I've written which might help.  Keep in mind, this is just a high-level conceptual overview where I try to avoid getting bogge…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Are you ready to place your question in front of subject-matter experts for more timely responses? With the release of Priority Question, Premium Members, Team Accounts and Qualified Experts can now identify the emergent level of their issue, signal…

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question