Solved

Exchange 2007 Public Folders: The mailbox recipient does not have a mailbox database

Posted on 2010-09-17
6
1,943 Views
Last Modified: 2012-08-14
I followed solution 1 from this article: http://technet.microsoft.com/en-us/library/bb727370(EXCHG.80).aspx to recreate the Folder Hierarchies through ADSI, I got the public folders back in Outlook but now every email that is sent to a mail enabled public folder says "The mailbox recipient does not have a mailbox database", does anyone know how I can get mail flowing back into the public folders? It's starting to back up in the Exchange Queue viewer.

Thank You!!
0
Comment
Question by:paclaiborne
6 Comments
 
LVL 32

Accepted Solution

by:
endital1097 earned 500 total points
ID: 33701804
you may need to mail-enable them again

run this to verify
get-publicfolder \ -recurse | fl Name,MailEnabled
0
 
LVL 3

Expert Comment

by:Cyrus9
ID: 33703008

Check the homeMDB attribute of the one of the Public Folders in ADSIedit and you might find that the homeMDB attribute is missing.

In that case copied the msExchOwningPFTree attribute of the Public Folder Store to the
homeMDB attribute of one of the mail-enabled Public Folders. And re-start the MSexchangeIS service.

Then try Sending an email to the mail enabled Public Folder and check if the mail gets delivered.
0
 

Author Comment

by:paclaiborne
ID: 33703027
I had to go into the Public Folder Management Console and Disable all mail enabled folders and then Re-Enable them for mail to start coming through, Thanks endital1097!!
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 

Author Closing Comment

by:paclaiborne
ID: 33703033
Thanks, you put me on the right track.
0
 
LVL 1

Expert Comment

by:comcitytechnology
ID: 36540418
I have this same issue, but disabling and re-enabling the folders doesnt fix the issue

Any other ideas?

0
 
LVL 1

Expert Comment

by:comcitytechnology
ID: 36540431
Further, when I create new PF with a new email address, the mail gets delivered to it.
When I create new PF and assign it mail from one that the mail is having issues with, it stuill doesnt get delivered.
So the issue seems to be with the email routing ratehr than with the public store.

Any ideas?
0

Featured Post

Secure Your Active Directory - April 20, 2017

Active Directory plays a critical role in your company’s IT infrastructure and keeping it secure in today’s hacker-infested world is a must.
Microsoft published 300+ pages of guidance, but who has the time, money, and resources to implement? Register now to find an easier way.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to install and use the NTBackup utility that comes with Windows Server.
You need to know the location of the Office templates folder, so that when you create new templates, they are saved to that location, and thus are available for selection when creating new documents.  The steps to find the Templates folder path are …
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

685 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question