Exchange 2007 Public Folders: The mailbox recipient does not have a mailbox database

I followed solution 1 from this article: http://technet.microsoft.com/en-us/library/bb727370(EXCHG.80).aspx to recreate the Folder Hierarchies through ADSI, I got the public folders back in Outlook but now every email that is sent to a mail enabled public folder says "The mailbox recipient does not have a mailbox database", does anyone know how I can get mail flowing back into the public folders? It's starting to back up in the Exchange Queue viewer.

Thank You!!
paclaiborneAsked:
Who is Participating?
 
endital1097Connect With a Mentor Commented:
you may need to mail-enable them again

run this to verify
get-publicfolder \ -recurse | fl Name,MailEnabled
0
 
Cyrus9Commented:

Check the homeMDB attribute of the one of the Public Folders in ADSIedit and you might find that the homeMDB attribute is missing.

In that case copied the msExchOwningPFTree attribute of the Public Folder Store to the
homeMDB attribute of one of the mail-enabled Public Folders. And re-start the MSexchangeIS service.

Then try Sending an email to the mail enabled Public Folder and check if the mail gets delivered.
0
 
paclaiborneAuthor Commented:
I had to go into the Public Folder Management Console and Disable all mail enabled folders and then Re-Enable them for mail to start coming through, Thanks endital1097!!
0
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

 
paclaiborneAuthor Commented:
Thanks, you put me on the right track.
0
 
comcitytechnologyCommented:
I have this same issue, but disabling and re-enabling the folders doesnt fix the issue

Any other ideas?

0
 
comcitytechnologyCommented:
Further, when I create new PF with a new email address, the mail gets delivered to it.
When I create new PF and assign it mail from one that the mail is having issues with, it stuill doesnt get delivered.
So the issue seems to be with the email routing ratehr than with the public store.

Any ideas?
0
All Courses

From novice to tech pro — start learning today.