IMAP to Exchange 2007 migration with Transporter Suite

Hi,

I have about 50 users with IMAP accounts that I am migrating to Exchange 2007 (on SBS 2008)

Im using Microsoft Transporter suite and follow the steps as per:

http://www.msexchange.org/articles-tutorials/exchange-server-2007/migration-deployment/migrating-pop/imap-exchange-server-2007-microsoft-transport-suite-part1.html

Everything goes great, I can see the it connecting to the IMAP account, extracting mail from all the folders and the wizard says it completes successfully. Except when I log into the corresponding exchange mailbox, it is empty, nothing from the IMAP account transferred??

2 things are odd about this..
- I get no errors from the Transporter wizard
- No matter what IMAP account I try to transfer (ranging in size from 200mb to 4gb) the process always finishes in 6-7 minutes

Any help appreciated, spent all day on this now!

In Progress

Finished Successfully
wojoinsAsked:
Who is Participating?
 
EE_AutoDeleterCommented:
wojoins,
Because you have presented a solution to your own problem which may be helpful to future searches, this question is now PAQed and your points have been refunded.

EE_AutoDeleter
0
 
wojoinsAuthor Commented:
As an update to this, its working now.

I had the Client Access Server (in this case the SBS server) DN wrong so had not properly givenimpersonation rights to the user I was logged in as using this command:

Add-ADPermission –Identity <CAS Server Distingued Name> -User <user> -ExtendedRights ms-Exch-EPI-Impersonation

Therefore the current user did not have enough permission to inject the extracted email into Exchange.

It would have been so helpful if Exchange threw up an error suggesting this rather than the wizard saying it completed successfully.. anyways..
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.