• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 795
  • Last Modified:

Cannot run ssh1 on solaris 8 running on a container. SSH gives error " Bad packet length 1349676916"

We replicated Solaris 8  server to a Container unsing Flar Archive. Server booted up normally but ssh is not working.  The SSH running on Solaris 8 is Sun SSH ver 1.2.30.

Here is the ssh out put. Can anybody help why I am getting "Bad packet length"  error? same  ssh binary works on on the Original Physical Solrais 8 server.

  ssh1 -v 10.102.177.39
SSH Version 1.2.30 [sparc-sun-solaris2.8], protocol version 1.5.
Standard version.  Does not use RSAREF.
ngzftpapp02-dev: Reading configuration data /etc/ssh_config
ngzftpapp02-dev: ssh_connect: getuid 17534 geteuid 0 anon 0
ngzftpapp02-dev: Allocated local port 1023.
ngzftpapp02-dev: Connecting to 10.102.177.39 port 22.
ngzftpapp02-dev: Connection established.
ngzftpapp02-dev: Remote protocol version 2.0, remote software version Sun_SSH_1.1
ngzftpapp02-dev: Waiting for server public key.
Local: Bad packet length 1349676916.
0
sirineni
Asked:
sirineni
  • 2
1 Solution
 
arnoldCommented:
you need to enable ssh version 1 mode by editing /etc/ssh/sshd_config.
There were/are issues with ssh protocol 1.
Any reason why you are not using ssh -v 10.102.177.39 and allow the client to negotiate the best available option?

If the issue deals with publickey access (no password)
use ssh-keygen -t dsa to generate a DSA private/public keys and ssh-keygen -t rsa for RSA.
then add the resulting id_dsa.pub and id_rsa.pub into the remote user's .ssh/authorized_keys2 location and you have achived access without the need to type in a password.

Have a look at installing openssl/openssh in /usr/local/ in place of Sun's ssh package.

0
 
arnoldCommented:
Oh,
I think you would have a
Protocol 2
change that to
Protocol 2,1

You might have to make sure that you have rsa1 host keys in /etc/ssh
ssh_host_key.pub

If I'm not mistaken when sshd is started if one of the host keys is missing, it will be regenerated prior to sshd starting listening.
0
 
balasundaram_sCommented:
Log output clearly states that the 'remote protocol is 2'

ssh1 -v 10.102.177.39
SSH Version 1.2.30 [sparc-sun-solaris2.8], protocol version 1.5.
Standard version.  Does not use RSAREF.
ngzftpapp02-dev: Reading configuration data /etc/ssh_config
ngzftpapp02-dev: ssh_connect: getuid 17534 geteuid 0 anon 0
ngzftpapp02-dev: Allocated local port 1023.
ngzftpapp02-dev: Connecting to 10.102.177.39 port 22.
ngzftpapp02-dev: Connection established.
ngzftpapp02-dev: Remote protocol version 2.0, remote software version Sun_SSH_1.1
ngzftpapp02-dev: Waiting for server public key.
Local: Bad packet length 1349676916.


As 'arnold' suggested, you need to enable both protocol "1 & 2".
0
 
sirineniAuthor Commented:
thanks for the responses.. got couple of feedbacks from the folks  to enable protocol ver 1 on target system  system but it is already enabled. As Arnold suggested I have copied the openssh's ssh binary from some other system and it worked.  then I got into SSH keys issues which I fixed it by stealing the public/private key from some other workng system.

though I did  not know the real cause for 'bad pakcet length' problem , was able to fix the issue by using openssh.

Thanks again for your responses.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now