Solved

server 2008 TS Web Access/Gateway

Posted on 2010-09-17
5
744 Views
Last Modified: 2013-11-21
I am having some difficulty setting up a test environment utilizing the TS Web Access and TS Gateway on Server 2008 (not R2).  I believe the base of the issue goes to the ports.  A quick breakdown of the situation is this:

I have a TS Gateway setup and showing the TS Apps of another server.  I am using my public IP which already has a webserver on it, so I changed the Website port of the TS Web Access to another port.

All of the above appears to be working fine, however when I go to connect to one of my RemoteApps it is giving me an error indicating the certificate and subject authority name don't match...however the certificate it is providing is for my mail server NOT the self signed cert from the Gateway.

So it appears that it is trying to communicate using either port 80 or 443 and hitting my web and/or email server.

Is there a way to have Gateway use ports other then 80/443?
0
Comment
Question by:americaneldercare
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 5

Expert Comment

by:AC_Nova
ID: 33715923
change the bindings for the site in IIS.
0
 

Author Comment

by:americaneldercare
ID: 33715974
To make sure we are both on the same page - I have the main portion of the web page working externally on another port other then 80.  It is when I go to launch the remote app that I am having an issue.  It is giving a certificate mismatch - but is referencing the SSL cert on my main website, not the self signed one on the test gateway server.

Are you indicating I need to adjust the SSL port in IIS and the system will automatically know to reference that other port?  Or were you intending the comment being for Port 80 to allow the TS Web to work on another port?
0
 
LVL 5

Expert Comment

by:AC_Nova
ID: 33716321
I had a similar problem and it was all down to certificates.  The server name must match what is specified in the SSL certificate for the TS Gateway server.  

also

If the Require server authentication check box is selected, consider the following:

If any client computers are running Windows Server 2003 with SP1, Windows Server 2003 with SP2, or Windows XP with SP2, you must configure the terminal server to use a Secure Sockets Layer (SSL) certificate. (You cannot use a self-signed certificate.)

If the RemoteApp program is for intranet use, and all client computers are running either Windows Server 2008 or Windows Vista, you do not have to configure the terminal server to use an SSL certificate. In this case, Network Level Authentication is used.

http://technet.microsoft.com/en-us/library/cc730673(WS.10).aspx
0
 

Author Comment

by:americaneldercare
ID: 33716487
The external test computer I am using is a Windows 7 Enterprise.

The issue with the certificate is slightly different then what you are mentioning - my issue is that when I get the error saying the certificate doesn't match, and View the certificate it is showing the SSL cert assigned to my email server NOT the certificate assigned to my gateway.  If i just change the listening port on the Gateway for SSL will the connection know to use another port? or do I need to specify somewhere that the SSL is on another port?

0
 

Accepted Solution

by:
americaneldercare earned 0 total points
ID: 33773197
I did not see it written on Microsofts website any where...but I was able to find a number of references indicated that the TS Gateway communication (not the IIS portion) is locked to port 443.  
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question