• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1017
  • Last Modified:

Frontpage 2003 WebDAV connectivity issue.

Hello all. I've got a bit of a problem here. I just brought up a new Windows Server 2008 R2 IIS 7.5 web server that permits WebDAV and FTPES connectivity, but we still have a number of users who are doing content editing using FrontPage 2003 (supported by MS through 2013, as I understand). We do not have any Frontpage extensions on the new server, but I had read and understood that FP 2k3 editors should still have WebDAV access to the server.

Immediately after rolling it out, I received complaints from Frontpage users about an inability to connect. After installing the FP 2k3 client on a Win7 computer myself, I have verified this error:

Unable to open 'https://URLREDACTED'. Server error: The Web server at "https://URLREDACTED" does not appear to have Windows SharePoint Services installed. Possible causes: 1. The wegb server  may not have the FrontPage Server Extensions installed. 2. The web server may be temporarily out of service. 3. If you are connecting thrrough aa proxy server, the proxu settings may be incorrect. 4. An error may have occurred in the web server. If this server does not support the FrontPage Server Extensions, frontPage may still  beable to publish to the server via FTP or WebDAV. Please select one of those options and try again.

The server does not have the FrontPage or SharePoint extensions installed, and I AM trying to connect via the WebDAV option!

Curiously, all of the other clients connect to WebDAV just fine. I've tried it in Expression, DreamWeaver, and through a mapped drive without experiencing any problems. FP 2003 seems to be rejecting the connections no matter what I do.

Is there a particular configuration required to get FP 2k3 working with WebDAV, or did I misunderstand the assertion that it would continue to work via WebDAV? I'd like for these users to move onto something else, but TPTB have decided that we'll support basic connectivity through the 2013 EOL date.

0
Arthalius
Asked:
Arthalius
  • 3
  • 2
1 Solution
 
James MurrellProduct SpecialistCommented:
just check if  Anti-Virus that is the problem. HTTP IIS SHTML Request intrusion detection prevents the "Reply To" working.
0
 
ArthaliusAuthor Commented:
Sadly, that wasn't it. I disabled both the local and server firewall, and the AV solutions on both the client and the server. There was no change in behavior. All other clients can connect to the WebDAV service, but FP 2003 doesn't recognize it.

I'm going to load up Wireshark and do a little packet analysis to see if I can figure out where this thing is dying.
0
 
ArthaliusAuthor Commented:
I should have tried that earlier. Turns out that it's dying when trying to establish the SSL connection. When I disabled the "Require SSL" setting for the WebDAV service, the connection worked just fine.

My problem, of course, is that we do require SSL for all authenticated services, because our users use the same authentication credentials  for other sensitive systems.

Does anyone know of any particular problems or limitations when using the FrontPage 2003 client with SSL WebDAV hosts? Could the problem be related to our multi-domain SSL cert?
0
 
James MurrellProduct SpecialistCommented:
Thanks for the extra info about SSL .
I have never tried with multi-domain ssl
0
 
ArthaliusAuthor Commented:
Closing this out as no solution was found. After a bit more digging, the problem appears to be a fundamental incompatibility between our server configuration (WebDAV running on IIS 7.5 web sites using host headers and Comodo multi-domain SSL certs). We sank a ton of time into this, but ended up saying "screw it", turned SSL off, and wrote the project off.

Thanks to those who tried to help, but no solution was found.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now