I can't run powershell in Windows 7

I have Windows 7 32 bit and when I run set-executionpolicy remotesigned it gives me the error I do not have rights to the registry.  I am in the administrators group.  This is my home machine, I am not on a domain.  How do I fix this so I can run scripts?  I powershell v2.
BrianSDGAsked:
Who is Participating?
 
chapmanjwConnect With a Mentor Commented:
You need to run PowerShell as administrator.  Right click, Run As Administrator.
0
 
jeremyjared74Commented:
You can download this registry entry to fix all those annoying privileged errors. Once you download it, just double click it to install. You will then have a right click menu to take ownership. http://www.sevenforums.com/tutorials/1911-take-ownership-shortcut.html

Well, that won't help you on this error, but it is nice to have. You can follow the instructions on this EE Post: http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_7/A_2846-Use-the-Administrator-account-by-default-in-Vista.html
0
 
thakurdineshCommented:
set-ExecutionPolicy : Access to the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\ShellIds
\Microsoft
.PowerShell' is denied.
At line:1 char:20
+ Set-ExecutionPolicy <<<<  RemoteSigned
    + CategoryInfo          : NotSpecified: (:) [Set-ExecutionPolicy], UnauthorizedAccessException
    + FullyQualifiedErrorId : System.UnauthorizedAccessException,Microsoft.PowerShell.Commands.SetExecutionPolicyComma
   nd


How to fix this?
 
Right click on Powershell shortcut and choose 'Run as Administrator'

Also note that if you have a 64-bit OS you need to set the execution policy for both the 32-bit and 64-bit version of PowerShell.
Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.