• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1056
  • Last Modified:

No value for $TERM and no -T specified

Hi,
We got a error message when trying to logon to a virtual Centos with ssh (putty). Every thing runs in Proxmox (OpenVZ).

The error message is: "No value for $TERM and no -T specified"

I have tried to set $TERM in /etc/bashrc and ~/.bashrc but with no succes. I have also tried to export the evironment från putty.

In the begining the virtual machine worked as it should but for some reason not any more. The machine runs but not the root session.
0
riverman
Asked:
riverman
  • 3
  • 3
1 Solution
 
JelcinCommented:
Hi, what term type did you try to set in ~/.bashrc?
0
 
rivermanAuthor Commented:
Hi Jelcin,
I tried xterm and xterm-color.

/Måns
0
 
JelcinCommented:
So you can't login as root remotely is this right? Can you use "sudo" when logged in as a user which can remotely login?

What did happen that the server refuses remote login as root? Means did you install or did you configure something?

Are there any further error messages? (e.g. in "/var/log/messages" or "/var/log/syslog" or "/var/log/auth.log")

What do you see in "/dev" directory?
What does the command "mount" output?
Is udev running? ("ps aux | grep udev")
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
rivermanAuthor Commented:
This what I found (doesn't look good):
/var/log/secure:
Sep 18 14:39:30 river-srv6 sshd[13641]: Accepted password for root from 82.117.102.70 port 63003 ssh2
Sep 18 14:39:30 river-srv6 sshd[13641]: pam_unix(sshd:session): session opened for user root by (uid=0)
Sep 18 14:39:30 river-srv6 sshd[13641]: error: openpty: No such file or directory
Sep 18 14:39:30 river-srv6 sshd[13641]: error: session_pty_req: session 0 alloc failed

/var/log/init.log
Loading default keymap (us): /etc/rc.d/rc.sysinit: line 396: /dev/tty0: No such file or directory
[FAILED]
0
 
JelcinCommented:
maybe this could help you...

http://24x7servermanagement.com/blog/?p=720
0
 
rivermanAuthor Commented:
Thanks very much!

The link you sent me was easy to follow and fixed all my problems!

I did this:
1. Edit the file /etc/rc.sysinit of the VPS server

2. Comment the line
#/sbin/start_udev

3. Add the following lines after /sbin/start_udev:

/sbin/MAKEDEV tty
/sbin/MAKEDEV pty

Then a reboot of the VPS.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now