We help IT Professionals succeed at work.

SBS 2008 Wireless clients no Internet

1,080 Views
Last Modified: 2012-05-10
SBS 2008 server acting as the DHCP server.
Netgear ProSafe VPN Firewall SRXN3205 (with built-in wireless) is the gateway.
All wired clients are getting IP addresses and are able to browse/access the local network and the Internet. Wireless clients are not getting assigned an IP address and have no network/Itnternet access. How do I get the Netgear to tell the SBS to assign IPs to wireless clients? Or is there a way?
Comment
Watch Question

Andre ThibodeauSenior IT Architect

Commented:
Sounds like the Wireless Access Point is providing DHCP address on a different network.

What IP subnet is the wired clients getting, and what subnet is wireless client getting?

run IPCONFIG /ALL and look at the address of the DHCP server on both a wired and wireless client and post the results.

What kind of Wireless Access Point are you using?  If this is a Wireless Router, then reconfig the router, turn off DHCP, and plug it in to your LAN using a LAN port on the Wireless Router, do not use the WAN port.

AT
stevenstrickIT Manager

Author

Commented:
The Netgear is a wireless firewall/router. The DHCP is turned off on the Netgear because the SBS 2008 is acting as the DHCP. There is only one network. The wired clients are getting IPs assigned by the SBS with no problems. The wireless clients are not being assigned an IP at all. When you run IPConfig /all you get the self-assigned IP address even though that computer shows it being connected to the wireless.
Andre ThibodeauSenior IT Architect

Commented:
For some reason I thought you were using two devices....

Try to manually assign an IP Address to a wireless client.

Can you ping network/internet if you manually assign?

AT
JamesSenior Cloud Infrastructure Engineer
CERTIFIED EXPERT

Commented:
When you have a router with wireless capability, it is not the DHCP on your server that serves the wireless clients. It is the wireless on the router which does this. The router ip address is the gateway address that the dhcp on your server looks to. Remember that the dhcp service does not have wireless capability so this is why it will not lease ip addresses to wireless clients. Enable the wireless on the router and then configure the ip range eg: if your LAN ip schema is 192.168.1.x > make sure that your wireless ip schema is the same. You can configure the ip range for wireless clients on the router eg: 192.168.1.50 - 100, which would give you 50 available ip addresses for your wireless clients.
Senior IT Architect
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
JamesSenior Cloud Infrastructure Engineer
CERTIFIED EXPERT

Commented:
You have misunderstood my comment. You are not enabling the dhcp on the router I am talking specifically for the wireless. You have to on the router configure the ip range when you enable wireless. This will then forward the requests to a dhcp server. If there is no range configured for wireless on the router then your dhcp server can no lease ip addresses to the wireless clients.
stevenstrickIT Manager

Author

Commented:
Turns out that I needed to upgrade the firmware on the Netgear. Once that was done, DHCP relay became available. I set that to the SBS and the wireless clients are now working. Thank you for your help. Much appreciated.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.