Trying to set up bridged networking in redhat linux guest vmware image

I have a guest redhat linux 5.1 image that was set up for NAT but I want to switch it to bridged so that I can access the image from another remote physical machine. However no ip address gets assigned (ip address is assigned just fine to the physical host) and when I go into the Network Configuration gui the eth0 device is shown as inactive and I'm unable to activate it.
opikeAsked:
Who is Participating?
 
bgoeringCommented:
Yeah, vmware has removed the virtual network editor in player so it is a bit inconvinient. What you will need to do is first shut down your vm and close it in player, then browse to and open the machinename.vmx file in an editor and change the parameters there,

Changed connection type from whatever it is (or add this line if missing) to
ethernet0.connectionType = "bridged"

Same for:
ethernet0.vnet = "vmnet0"

It will need to specify vmnet0 from bridged.

Open the vm back up in player and it should be on bridged

Good Luck
0
 
bgoeringCommented:
Any error in /var/log/messages? You could try deleting the adapter and then creating a new adapter and configure that, though you really shouldn't have to. What VMware product? Workstation? What version?
0
 
opikeAuthor Commented:
It's vmware player 3.1.1.

This is what gets written to /var/log/messages when I try to activate eth0:

Sep 17 20:41:53 oracleepm kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready
Sep 17 20:41:55 oracleepm kernel: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Sep 17 20:41:55 oracleepm dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
Sep 17 20:41:56 oracleepm avahi-daemon[3872]: New relevant interface eth0.IPv6 for mDNS.
Sep 17 20:41:56 oracleepm avahi-daemon[3872]: Joining mDNS multicast group on interface eth0.IPv6 with address fe80::20c:29ff:fecb:c268.
Sep 17 20:41:56 oracleepm avahi-daemon[3872]: Registering new address record for fe80::20c:29ff:fecb:c268 on eth0.
Sep 17 20:41:58 oracleepm dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
Sep 17 20:42:01 oracleepm dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
Sep 17 20:42:04 oracleepm dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
Sep 17 20:42:12 oracleepm dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
Sep 17 20:42:29 oracleepm dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 11
Sep 17 20:42:42 oracleepm dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
Sep 17 20:42:59 oracleepm dhclient: No DHCPOFFERS received.
Sep 17 20:42:59 oracleepm dhclient: Trying recorded lease 192.168.2.9
Sep 17 20:42:59 oracleepm avahi-daemon[3872]: New relevant interface eth0.IPv4 for mDNS.
Sep 17 20:42:59 oracleepm avahi-daemon[3872]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.2.9.
Sep 17 20:42:59 oracleepm avahi-daemon[3872]: Registering new address record for 192.168.2.9 on eth0.
Sep 17 20:43:03 oracleepm avahi-daemon[3872]: Withdrawing address record for 192.168.2.9 on eth0.
Sep 17 20:43:03 oracleepm avahi-daemon[3872]: Leaving mDNS multicast group on interface eth0.IPv4 with address 192.168.2.9.
Sep 17 20:43:03 oracleepm avahi-daemon[3872]: iface.c: interface_mdns_mcast_join() called but no local address available.
Sep 17 20:43:03 oracleepm avahi-daemon[3872]: Interface eth0.IPv4 no longer relevant for mDNS.
Sep 17 20:43:03 oracleepm avahi-daemon[3872]: Interface eth0.IPv6 no longer relevant for mDNS.
Sep 17 20:43:03 oracleepm avahi-daemon[3872]: Leaving mDNS multicast group on interface eth0.IPv6 with address fe80::20c:29ff:fecb:c268.
Sep 17 20:43:03 oracleepm avahi-daemon[3872]: Withdrawing address record for fe80::20c:29ff:fecb:c268 on eth0.
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
bgoeringCommented:
Make sure the connect at power on is checked
0
 
darrickhartmanCommented:
If you want to change the vmware networking options for the guest, make sure the host pc supports this change.  You may have set up the host pc to only support NAT.  If that's the case, you'll need to re-run the vmware-config.pl script and change the networking options on the host.

After you've done that, you'll need to restart the vmware service on the host, then make any changes to your guests.
0
 
opikeAuthor Commented:
I'm running player on a host pc running windows. I wasn't able to find a vmware-config script.
0
 
bgoeringCommented:
On further reflection you probably won't need the ethernet0.vnet parm - I think that is only for network type of custom
0
 
opikeAuthor Commented:
Still working on this...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.