Windows fire wall blocking directory listing.

We cannot get windows firewall to pass ftp file listings.  We have changed serveral ports and it will work when we turn the firewall off.  This problem is there with server 2003 or 2008 ftp or Filezilla ftp server.
wcgnetAsked:
Who is Participating?
 
sneak_nakataConnect With a Mentor Commented:
what OS do u use ? I think it is the firewall configuration u should allow 21 and make sure u check firewall zone.

By the way try to get the latest file zilla client.
0
 
printnix63Connect With a Mentor Commented:
Hi,

eventually you have a look at:
http://en.wikipedia.org/wiki/File_Transfer_Protocol for a bit more backgrount on FTP (+ references listed)

basically FTP needs port 21 and port 20 for communication. If all else fails try Passive Mode.
Passive Mode would be my guess to help with the firewall.
0
 
wcgnetAuthor Commented:
I am using windows server 2003 and 2008.  Both port 20 and 21 are open.
0
 
JamesConnect With a Mentor Senior Cloud Infrastructure EngineerCommented:
I found out that there seems to be a problem with the Windows Firewall. On the Exceptions tab I had made an exception for FTP on TCP port 21 but as it turned out that did not work but I had to go to the Advanced tab, select my connection under Network Connection Settings and click the Settings button. From there check FTP Server and voìla, it works.
0
 
wcgnetAuthor Commented:
I got the ftp to work after a grea deal of searching.  The problem was going to command promt and changine windows ftp to passive mode with some ports assigned to it.  We did 5010 to 5020.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.