Solved

Connecting a Mac and Win XP PC via RCD or CoRD

Posted on 2010-09-18
17
691 Views
Last Modified: 2012-08-14
I have a year old MacBook Pro running OSX 10.5.8, and i connect to the web via Apple Express which is connected to my Verizon Fios router. I would like to connect, via RDC or CoRD, to my Win XP desktop, which is also connected to the same router. I cannot connect after entering the PC's IP address. Am I missing a step or is this connection  ot possible? Thank you to all in advance.
0
Comment
Question by:narroyo99
  • 8
  • 4
  • 4
  • +1
17 Comments
 
LVL 8

Expert Comment

by:et01267
ID: 33710580
Do you have security software or firewall running on the XP machine?  You may  need to create an exception for the Windows Remote Desktop protocols.  Also, in the Windows Firewall, you need to make sure that the checkbox "Do not allow exceptions" is NOT checked.

I presume you have actually turned on Remote Desktop (which is only available on Win XP Pro - you didn't say which version of XP you have).  Open the System control panel and look at the Remote tab.

Do you have basic network connectivity between the machines?  On the mac, open a Terminal window and type

ping <IP address of XP machine>

(you can also do this in a CMD / DOS window on XP)
0
 
LVL 4

Expert Comment

by:Nice-Ghaza
ID: 33710984
Dear
             xp     Ip machine   192.168.1.33  like that
                mask address   255.255.255.0
                Gate way          192.168.1.1     like that
                           DNS        192.168.1.2    LIKE THAT
                         ADNS        192.168.1.3
0
 

Author Comment

by:narroyo99
ID: 33711099
i have xp pro, and my windows firewall is turned off. i run zone alarm security for anti virus, firewall, etc. i have not configured its firewall. Yes, i have turned on remote desktop. i don't know if i have basic network connectivity; i assumed that if both the mac and the xp were connected to the same router, they would be able to connect to each other. i opened up the terminal app on the mac and ping the ip address of the xp pro pc. the results are:

64 bytes from 98.116.131.161: icmp_seq=162 ttl=63 time=3.367 ms

this is one line of many; it repeats infinitely.

thanks for your help.
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 53

Expert Comment

by:strung
ID: 33711182
Something is out of whack on your network. 98.116.131.161 is a routable internet address. Your computers should have local private IP addresses in one of the following ranges:

10.0.0.0 through 10.255.255.255
 172.16.0.0 through 172.31.255.255
 192.168.0.0 through 192.168.255.255

I suspect your Verizon Fios is not doing network address translation, but is connecting directly to the internet.

What you really need is an Airport Extreme, not an Airport Express. The Extreme should be connected to the FiOS, and the PC connected to one of the Extreme's ethernet ports. Then both the PC and the Mac will get IP addresses in the 10.x.x.x range and you will be able to do RDP.

Is it too late to exchange the Express for an Extreme?
0
 

Author Comment

by:narroyo99
ID: 33711231
the ip address that i pinged is the one from my xp pro pc. i googled "what is my ip" and that's what i got. i can always purchase an airport extreme if i have to, but let me ask you another question. perhaps the extreme help me resolve another problem: i would like to purchase an NAS type storage device that i could plug into my routers and access from both my pc and mac, to back up files and to store my audio files, which i would play from either computer. RAID capability is not a priority (although perhaps it should be) so i was thinking of a Seagate or Lacie device that can be accessed by both the PC and Mac. any opinions? thanks again.
0
 
LVL 8

Expert Comment

by:et01267
ID: 33711396
The "what is my IP address" is probably giving you your external IP address, not the IP address on your LAN.

on your xp machine, in a CMD window, type

ipconfig

You should see a list of network interfaces, probably only one, with different IP Address info.  It should be either 10.xxx.yyy.zzz or 192.168.yyy.zzz (or possibly 172.xxx.yyy.zzz) as strung suggests.  This is what mine looks like

Ethernet adapter Local Area Connection 3:

        Connection-specific DNS Suffix  . : localdomain
        IP Address. . . . . . . . . . . . : 10.211.55.4
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 10.211.55.1


Use that IP address when connecting via CoRD from your Mac.

0
 

Author Comment

by:narroyo99
ID: 33711878
i will try that, et01267. any other opinions from anybody on the airport extreme and an nas device?
0
 
LVL 53

Accepted Solution

by:
strung earned 500 total points
ID: 33711977
If the IP address you are getting by using ipconfig is in the private IP range set out above, you don't need an Extreme, the Express will do.

You may not have the Express set up correctly, though. I assume it is connected to the Fios with an ethernet cable and you are connecting to the Express wireless from the Mac. If that is the case the Express has to be set up to "create a wireless network" (under the Wireless tab) and "bridge mode" under the internet tab.

Let us know what the IP address is that you get using Ipconfig /all on the PC and by checking the Network Preference Panel on your Mac under the Airport tab.
0
 

Author Comment

by:narroyo99
ID: 33717096
i will post this data tonite and we'll see what happens. also, since we're on the same topic, and assuming the above works, how can i connect two printers to both the new "pc and mac network" so that they are both usable by both the pc and mac.  i have one hp non-networked printer connected directly to the pc via cable, and one hp connected wirelessly to the mac. thanks.
0
 
LVL 53

Expert Comment

by:strung
ID: 33717229
Printer sharing should work. See the tutorials here:  http://www.ifelix.co.uk/tech/windowsxp.html

Printer sharing will work best if you install Bonjour for Windows on the PC:  

http://support.apple.com/kb/DL999


0
 
LVL 8

Expert Comment

by:et01267
ID: 33717298
Dealing with printers in a mixed Mac / PC network can be a can of worms, depending on how things are configured on your network.

Your HP printer connected wirelessly should continue to work from the Mac, but this may depend on how you set it up originally.  And the PC should find it as well.

The cable-connected printer should be shared from the PC, and the Mac might be able to find it; MacOS 10.5 doesn't do this as well as 10.6, but you can make it work.

However, if you have problems with printing you should start a new question in the appropriate areas.

Let's get your basic networking issues sorted out here first.
0
 

Author Comment

by:narroyo99
ID: 33775855
ok, i followed all the comments and i was able to connect via rdc and cord. my ip address was incorrect, as noted, and i had to turn off my Zone Alarm (ZA) firewall. to complete the question, how do i configure ZA so that the firewall is working but allows access to my mac via rdc or cord? also, it seems that i should post my printer sharing problem as a separate question. any comments on these issues are appreciated. thanks to all.
0
 
LVL 53

Expert Comment

by:strung
ID: 33778398
If you want to use Microsoft Terminal Server (aka Remote Desktop Protocol or RDP) through a firewall, you need to open TCP port 3389.
0
 

Author Comment

by:narroyo99
ID: 33779187
how do i "open" a port? i am a newbie to all this, so thanks for your patience.
0
 
LVL 8

Expert Comment

by:et01267
ID: 33779495
You read the documentation that comes with zonealarm.

By default, most firewalls block all incoming network connections.  Network connections (whether incoming or outgoing) are distinguished by (amongst other thing) the port they connect to; for example, HTTP connections use port 80 by default.

If you want to allow certain network protocols to connect to your machine through a firewall, you need to open the port that it uses.  The port for RDP is 3389 (by default) as strung has noted.  There should be a fairly obvious menu or panel on ZA where you can "open a port" or "make an exception" (which is the same thing).  
0
 

Author Comment

by:narroyo99
ID: 33879270
i was able to connect via rdc and cord if i changed a setting within zone alarm. i lowered the "internet zone security" and the "trusted zone security" levels from high to medium. I use ZA security suite 9.3; does anyone know how to configure it so that only one port is open, as recommended in several expert comments?
0
 

Author Closing Comment

by:narroyo99
ID: 34016883
thanks strung!
0

Featured Post

Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Worried about if Apple can protect your documents, photos, and everything else that gets stored in iCloud? Read on to find out what Apple really uses to make things secure.
An article on effective troubleshooting
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

803 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question