Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

digital camer USB detection

Posted on 2010-09-19
23
Medium Priority
?
414 Views
Last Modified: 2012-05-10
Hi,

I have a Samsung PL60 digital camera. Previously I used to just connect the camera to my PC via a USB port and copy the images over via windows explorer. Now, when I try and connect the camera with the USB, nothing happens. No message in the bottom right saying device detected and it doesn't appear as a drive in My computer (like it used to do.)?

Any ideas why this is happening and how I can rectify it? ... I am using Windows XP.

Thanks,
0
Comment
Question by:Eternal_Student
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 5
  • 3
  • +5
23 Comments
 
LVL 14

Accepted Solution

by:
Farzad Akbarnejad earned 200 total points
ID: 33710711
Hello,
Turn ON the camera then connect to Windows XP. Also make sure that use the latest Windows XP Service Pack (SP3)

-FA
0
 
LVL 23

Expert Comment

by:edbedb
ID: 33710719
Could be the USB controller in the camera has gone bad. I would try connecting it to another computer to confirm.
0
Introducing the WatchGuard 420 Access Point

WatchGuard's newest access point includes an 802.11ac Wave 2 chipset, providing the fastest speeds for VoIP, video and music streaming, and large data file transfers. Additionally, enjoy the benefits of strong security as the 3rd radio delivers dedicated WIPS protection!

 
LVL 18

Author Comment

by:Eternal_Student
ID: 33710721
@edbedb - I have just connected the camera to a laptop via USB, so it isnt that.

Also the USB port works fine on my PC, I tried to add another device and it works fine.
0
 
LVL 6

Expert Comment

by:collins23
ID: 33710729
When you put in the camera , is there any new device installed in device management ? if so you might want to uninstall whatever is installed so that it can re-install the driver next time you insert the cable.
0
 
LVL 23

Expert Comment

by:edbedb
ID: 33710733
Open the Device Manager (Start>Run>devmgmt.msc) and watch it as you plug in the camera. Is there any activity? Any flagged devices?
0
 
LVL 93

Expert Comment

by:nobus
ID: 33710748
then your cable, or camera is bad, if it does not work on another pc.
you can also try another SD card..or reset the camera -if you have that option
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 33710751
There is no activity in device manager when I add it.

Just a side not ... I seem to have 3 exclamation marks in device manager.

- Multimedia Audio controller
- SCSI and RAID controllers (unknown device)
- Microsoft Kernel DLS synthesizer

But I guess they ^ are unrelated?
0
 
LVL 23

Assisted Solution

by:edbedb
edbedb earned 200 total points
ID: 33710772
If you have already tried a different USB port I would try removing all the USB Devices in the Device Manager then restarting the computer.
0
 
LVL 14

Expert Comment

by:Farzad Akbarnejad
ID: 33710780
Hello,
If you haven't free drive letter after CD/DVD drives this may be happened. For example if you have mapped network drive.

-FA
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 33710839
Hi edbedb, how do you mean remove all USB devices in the device manager?
0
 
LVL 7

Assisted Solution

by:Daxit
Daxit earned 200 total points
ID: 33710862
Hello

If you tried to connect the camera to another pc (using the same cable of course) and it works fine the problem is in your pc.

Try to connect to the other usb ports of your pc, one by one, there might be more kind of usb controllers on the pc and not necessarily all of them have to be affected.

The yellow marks in the device manager are appereantly not related to your problem, but I would take care to fix it anyway, retrieve the updated drivers from internet and install them. The yellow marks somehow spot out the fact that there are some mangles in your devices configuration.

Then try to remove all usb drivers and reinstall them, if you want to be sure that new updated driver are loaded instead of the same drivers you just removed you should either install them completely manually pointing to the path were you place the new updated drivers that you can download from the web.

If win Xp tricks you and reinstall old drivers anyway follow this procedure, open a any folder and go to the folder options, you find it in the menu bar, here set the OS to show hidden and system files and apply, if you can then see the hidden files  it is ok if you cannot see them and reopening the dialog you see that your settings are overidden and resetted to hide it you have a virus in action.

If you have the virus then you know what the problem is and you should first remove it.

If you can see all hidden files etc. the you can proceed as written below.
Go to the inf folder in the windows folder, select all, right click and cut, move to windows folder, right click and create a new temp folder, paste here (some files might not be removed, ignore this) now reinstall your drivers, replace the content of Inf folder in the original position.

After this you are sure to have new drivers.

Try also to see if your pc and the sd card ( I suppose it is a sd, I mean the memory card in general) is infected by a virus, you can do it scanning it on another pc (take care not to infect it too if this is the case). Retrieve all of your data from the card too so not to risk a loss during the fix attempts.

Many times this problems can occurr also due to malwares in action, you should check properly about this.

Use Virus effect remover
http://www.virussecurelab.com/downloads.html

It contains a good tool that automatically attempts to remove the typical mangles malwares do create in the system registry, virus effect remover is especially good to remove problems coming from viruses that are very difficult to remove with regular antivirus programs (and much more), it can be installed in parallel to any other antimalware product as it does not have any on access scanning system, so does not interfere.

Will also vaccinate your storage devices from the autorun.inf infection method.

Your camera behaves as a regular removable storage media when connected as you did not mention any special driver coming with it, I visited Samsung support site and found this software bounded to the camera, I gues there is not a driver, but check it out, you never know.

So the fact that it comes not to be recognized at all meanwhile other devices do is strange, by the way you should try to connect a usb memory key to see if the system is reacting in the same way, the problem might be specific for removable storage media.

Another very useful tool you can use to check the storage devices is in the control panel>administrative tools>computer manager and inside this tool choose disk manager, it will show you what the OS recognize.

I wrote you here many informations that might help or solve the case, check what happens and if unsuccesful continue posting us informations so that we can better figure out what can it be.

Bye
0
 
LVL 93

Assisted Solution

by:nobus
nobus earned 200 total points
ID: 33710955
>>  Just a side not ... I seem to have 3 exclamation marks in device manager.

- Multimedia Audio controller
- SCSI and RAID controllers (unknown device)
- Microsoft Kernel DLS synthesizer                                 <<<<

i would fix this first; points to a corrupt OS, or driver problems.
no use in persuing the camera problem before this is solved.
--------------------
if it is recent a system restore can help
you can try sfc  : http://www.updatexp.com/scannow-sfc.html      
or a repair install                 http://www.michaelstevenstech.com/XPrepairinstall.htm      

then update your drivers !
                             
0
 
LVL 7

Expert Comment

by:Daxit
ID: 33711292
Hi

About restoring the system I often found out that is really fast to follow this way than anyone else. The problem is that the xp embedded restore system is not really reliable, and sometimes does not work or brings up to a even worst situation.

I noticed that in win 7 the situation is much different and the embedded restore system is extremely improved, seems to be reliable and well working.

So normally when the issue is complicated or for any reason the repair attempts do not work, and at the same time the system might be already extremely fragmented, screwed in various ways and "weared out" if a recursive backup was done at a certain good state of the system, the fast thing is to restore it and eventually add again what was left out at that day.

But as almost 90% of users just do not take this preventive step, it is also convenient to backup everythig and reinstall the OS from scratch, of course as soon as the new system is installed a recursive backup must be done, later on when a fully configured system is done the recursive backup should be repeated and again must be repeated each time major changements are implemented.

For example if the pc was so prepared also in this specific case here exposed by Eternal Student  was realistically possible to obtain back a pristine system in a 15 minutes.

Of course it works only on software troubles, if the hardware is involved it would not help until phisically repaired.

Bye

0
 
LVL 63

Assisted Solution

by:SysExpert
SysExpert earned 200 total points
ID: 33713455
SInce it works on another system, then I would suggest either a driver or hardware issue.

You can check for any samsung related drivers in Device maanger etc.

Also , the fact that you have 3 unknown devies without drivers, may be affecting the camera USB interface.



I hope this helps !
0
 
LVL 30

Expert Comment

by:Sudeep Sharma
ID: 33730494
Hi,

Just make sure that the service named "Windows Image Acquisition (WIA)" is running on your system before connecting the camera to your Windows XP system.

I could be wrong but i happened with me once.
Click on Start --> Run --> type services.msc and click on OK. Scroll down and you would see Windows Image Acquisition (WIA). Set it to Automatic if it is not already.

I hope that would help

Sudeep
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 33768662
I have tried all of your suggestions and it still fails to be detected. Any other ideas?
0
 
LVL 93

Expert Comment

by:nobus
ID: 33768682
>>  I have tried all of your suggestions   <<   please post what you tried - and the results.
still errors in Device manager?
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 33771383
Here is a list of things I have tried ...

- Upgraded to service pack 3, windows is up to date

- I uninstalled all usb ports from device manager and rebooted

- Other devices work in the USB port, including a USB storage stick

- Camera works on other machines when put in USB port

- Removed Samsung Camera from device manager (it was hidden as unconnected)

- There is no virus or malware

- Windows Image Acquisition set to automatic


The only thing I haven't tried is a repair install ... as that sounds a bit drastic to me!

I still have errors in device manager to do with my sound card but im working on that as a separate issue. I dont think it is related?
0
 
LVL 93

Expert Comment

by:nobus
ID: 33771626
ok - i see the picture more clearly now.  usb problems are often not as easily repaired - as they come; here some tips :
Here a list of things to try :
-from Device manager scan for new hardware
-in device manager>view tab, click "show hidden devices" and delete all usb entries and hidden devices,  reboot and test
-then you can download the latest drivers for the chipset, and reinstall it to update the USB root hubs
-start>run>diskmgmt.msc      check if the usb devices show up in disk management, then run :   start>run>services.msc
In the listing look for removable storage service.
If it is set to Auto, and not started, then start it : click the Start link in the top left...
-In c:\windows\inf, look for usbstor.inf    -  If it is not there, you can copy it from another PC..When you find it, right click it and select Install

i fthe camera was installed with software, you can always uninstall it, then reinstall it again (it can be it's corrupted)
you did test the camera also on other usb ports?
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 33777417
OK, it turns out that disabling the onboard sound fixed this problem so it looks like this issue was being caused by that device and or the drivers associated with it.

It's a bit tricky to award points but I just wanted to say thanks for your help everyone.
0
 
LVL 18

Author Closing Comment

by:Eternal_Student
ID: 33777453
/
0
 
LVL 93

Expert Comment

by:nobus
ID: 33779700
tx for the feedback!
0

Featured Post

Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Great sound, comfort and fit, excellent build quality, versatility, compatibility. These are just some of the many reasons for choosing a headset from Sennheiser.
This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
This video teaches viewers how to process images for a time-lapse video. Programs required: Adobe Lightroom, Adobe After Effects, Video Editing Program. In Adobe Lightroom: Import sequence image files into Adobe Lightroom: Develop settings of an I…
I designed this idea while studying technology in the classroom.  This is a semester long project.  Students are asked to take photographs on a specific topic which they find meaningful, it can be a place or situation such as travel or homelessness.…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question