WSUS - Excel report generation fails with an error

Posted on 2010-09-19
Last Modified: 2012-05-10
I have WSUS 3.0 installed on one of the Domain Controllers in our network.

Whenever I want to generate a report in Excel format I receive the following error:

An error occurred during local report processing.
An error occurred during rendering of the report.
An error occurred during rendering of the report.
This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.

I passed by a Microsoft KB article:
I do not know if this applies for me.

Any help will be greatly appreciated.

Question by:msallam
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2

Accepted Solution

sweeneya earned 500 total points
ID: 33711947
Sounds like your server is set for FIPS security compliance, is this required on your servers?
To turn it off you can change the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\fipsalgorithmpolicy registry subkey from 1 to 0. May require a reboot to work properly.

Author Closing Comment

ID: 33712136
You got it!!
Thanks a lot... It worked.

Author Comment

ID: 33713694
Hi sweeneya,

After I applied your fix, and worked with WSUS reports.
I found out that the same error popped up today when I tried to generate some excel report.
I went to the registry key, I found out that it was reverted back to its old value although I did not touch it.
Have an idea why might this have happened? How can I make the change permanent?
I do not want to restart the server every now and then to produce an Excel report.


Expert Comment

ID: 33713726
Check the local security policy, GPO's or domain controller policy for the following setting and see it is enabled there:
Local Policies -> Security Options -> System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing

Author Comment

ID: 33714475
Yes, I guess that will be the one. It was configure on the Default Domain Controllers GPO.
This does not need a restart actually.

I will try today after working hours and tell you.
Thanks again

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Numerous times I have been asked this questions that what is it that makes my machine log on so slow, there have been cases where computers took 23 minute exactly after taking password and getting to the desktop. Interesting thing was the fact th…
Back in July, I blogged about how Microsoft's new server pricing model, combined with the end of the Small Business Server package, would result in significant cost increases for many small businesses (see SBS End of Life: Microsoft Punishes Small B…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question