[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 605
  • Last Modified:

exchange outlook clients unable to connect to server SBS 2008 with Exchange 2007 server

I have a new installation of SBS 2008.
The external domain name is for example "mycompany.com"
The internal domain is "mc.local"
OWA I can logon with user id and password but
Outlook 2007 keeps asking for user id and password. Tried many combinations but nothing seems to authenticate.
0
Terrymac_Computer_Guy
Asked:
Terrymac_Computer_Guy
  • 7
  • 3
  • 2
  • +2
2 Solutions
 
kenyclCommented:
username and password should either be domain/username
or username@domain

server should be mc.local on your outlook
0
 
Robert HolmesCommented:
To clarify your question is the computer accessing the exchange server with Outlook 2007 is on the internal network or externally?
0
 
Robert HolmesCommented:
One solution to test is to install the latest service packs for Exchange Server 2007 as I have seen this problem be fixed by a service pack update.
0
Microsoft Certification Exam 74-409

VeeamĀ® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
Terrymac_Computer_GuyAuthor Commented:
both these don't work
Usually Outlook 2007 is fine with automatically setting correctly
The only difference with this SBS 2008 install from others I've done is the external and internal domain are named differently (usually it mycompany.comand mycompany.local)  
0
 
Terrymac_Computer_GuyAuthor Commented:
On the internal network. I'm having the same problem with all the workstations internally.
Latest service packs are applied for both SBS 2008 server and Exchange 2007
0
 
FDiskWizardCommented:
Are the Exchange server event logs showing anything? App and Security...
Maybe time to whip out some diagnostics. I can only think of DSDiag off the top of my head
http://smtp25.blogspot.com/2007/10/dcdiag-verify-domain-controller-health.html

I think there is an SMTPDiag for Exchange testing.
Oh, the other 2 I was trying to think of DCDiag and Netdiag.

Try those.
Also, Is Outlook doing RPC over HTTP? Try it if not.
Are all the normal services running on the server? Can you browse to a share on the server?
If you recreate a mail profile on the PC, does it resolve the user's name correctly?

0
 
Terrymac_Computer_GuyAuthor Commented:
Browsing share works fine
it looks like rpc over http is setup by default could it be the firewall preventing this? Even though I'm locally on the domain does it authenticate over the internet to get to the exchange server?
0
 
Robert HolmesCommented:
It wouldn't hurt checking the firewall.
0
 
Terrymac_Computer_GuyAuthor Commented:
Also looking at the send receive progress it shows sending successfull and receiving not succesful
0
 
kenyclCommented:
try testing it from here and see what results you get

https://www.testexchangeconnectivity.com
0
 
Cliff GaliherCommented:
MU does not install Exchange service packs. You *must* actually go, download, and install them. This is known conflict between a security patch and older versions of Ex2007. Add Exchange SP3 to resolve the issue.
-Cliff
 
0
 
Terrymac_Computer_GuyAuthor Commented:
Cliff,

Can you explain what SP3 does to correct this so I can understand better what is broken.

I also just did a test on a workstation with Outlook 2007 and let it automatically set outlook up and up came the user id and password prompt. I then backed out a couple of steps and checked setup Outlook 2007 manually and it worked.

I looked at the outlook exchange more settings and this time the only thing it didn't fill in setup is the outlook anywhere on the connection tab. So I'm gueesing it has a problem with this.

Also any advice for installing Exchange SP3?
0
 
Cliff GaliherCommented:
The short answer is that a security update (KB973917) enabled windows authentication on a global level where it was previously disabled.
This causes an issue with how Exchange is set up on SBS by default, where it uses user-level authentication instead of kernel-level authentication, and that conflict causes repeating prompts.
Exchange SP1 UR8 (and by proxy SP2 and SP3) disabled kernel-level authentication, thus preserving the windows authentication that KB973917 enables, but in a way that no longer conflicts with the RPC authentication needs of Exchange for autodiscovery/RPC/MAPI.
-Cliff
 
0
 
Terrymac_Computer_GuyAuthor Commented:
Thanks cliff,

We will try this and see. I've had a look at this link here for instructions installing to SBS 2008.

http://support.microsoft.com/kb/982423

We didn't install Forefront so won't have to disable it.

Will let you know how we made out.
0
 
Terrymac_Computer_GuyAuthor Commented:
Thanks Cliff this cleared up the error. Since you explained in more detail to help me understand I'll award you more of the points.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 7
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now